aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 2233b5cad..87b05862c 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -71,6 +71,10 @@ check_PROGRAMS = \
71 $(TESTING_TESTS) 71 $(TESTING_TESTS)
72endif 72endif
73 73
74if HAVE_REST
75REST_PLUGIN=libgnunet_plugin_rest_namestore.la
76endif
77
74if ENABLE_TEST_RUN 78if ENABLE_TEST_RUN
75AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; 79AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
76TESTS = \ 80TESTS = \
@@ -81,10 +85,6 @@ endif
81lib_LTLIBRARIES = \ 85lib_LTLIBRARIES = \
82 libgnunetnamestore.la 86 libgnunetnamestore.la
83 87
84if HAVE_REST
85lib_LTLIBRARIES += libgnunet_plugin_rest_namestore.la
86endif
87
88 88
89libgnunetnamestore_la_SOURCES = \ 89libgnunetnamestore_la_SOURCES = \
90 namestore_api.c \ 90 namestore_api.c \
@@ -148,7 +148,10 @@ gnunet_service_namestore_LDADD = \
148plugin_LTLIBRARIES = \ 148plugin_LTLIBRARIES = \
149 $(SQLITE_PLUGIN) \ 149 $(SQLITE_PLUGIN) \
150 $(POSTGRES_PLUGIN) \ 150 $(POSTGRES_PLUGIN) \
151 $(FLAT_PLUGIN) 151 $(FLAT_PLUGIN) \
152 $(REST_PLUGIN)
153
154
152 155
153libgnunet_plugin_namestore_flat_la_SOURCES = \ 156libgnunet_plugin_namestore_flat_la_SOURCES = \
154 plugin_namestore_flat.c 157 plugin_namestore_flat.c