aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index b71896894..5142058ad 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -15,6 +15,7 @@ if USE_COVERAGE
15 XLIBS = -lgcov 15 XLIBS = -lgcov
16endif 16endif
17 17
18
18if HAVE_SQLITE 19if HAVE_SQLITE
19SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la 20SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
20SQLITE_TESTS = test_plugin_namestore_sqlite \ 21SQLITE_TESTS = test_plugin_namestore_sqlite \
@@ -38,6 +39,7 @@ SQLITE_TESTS = test_plugin_namestore_sqlite \
38 test_namestore_api_tx_rollback_sqlite 39 test_namestore_api_tx_rollback_sqlite
39endif 40endif
40 41
42
41if HAVE_POSTGRESQL 43if HAVE_POSTGRESQL
42POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la 44POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
43POSTGRES_TESTS = test_plugin_namestore_postgres \ 45POSTGRES_TESTS = test_plugin_namestore_postgres \
@@ -58,8 +60,10 @@ POSTGRES_TESTS = test_plugin_namestore_postgres \
58 test_namestore_api_monitoring_existing_postgres \ 60 test_namestore_api_monitoring_existing_postgres \
59 test_namestore_api_zone_to_name_postgres \ 61 test_namestore_api_zone_to_name_postgres \
60 perf_namestore_api_zone_iteration_postgres \ 62 perf_namestore_api_zone_iteration_postgres \
61 test_namestore_api_tx_rollback_postgres \ 63 test_namestore_api_tx_rollback_postgres
62 test_namestore_api_edit_records_postgres 64if HAVE_EXPERIMENTAL
65POSTGRES_TESTS += test_namestore_api_edit_records_postgres
66endif
63endif 67endif
64 68
65if HAVE_SQLITE 69if HAVE_SQLITE
@@ -443,6 +447,7 @@ test_namestore_api_tx_rollback_postgres_LDADD = \
443 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 447 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
444 $(top_builddir)/src/util/libgnunetutil.la 448 $(top_builddir)/src/util/libgnunetutil.la
445 449
450if HAVE_EXPERIMENTAL
446test_namestore_api_edit_records_postgres_SOURCES = \ 451test_namestore_api_edit_records_postgres_SOURCES = \
447 test_namestore_api_edit_records.c 452 test_namestore_api_edit_records.c
448test_namestore_api_edit_records_postgres_LDADD = \ 453test_namestore_api_edit_records_postgres_LDADD = \
@@ -451,6 +456,7 @@ test_namestore_api_edit_records_postgres_LDADD = \
451 libgnunetnamestore.la \ 456 libgnunetnamestore.la \
452 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 457 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
453 $(top_builddir)/src/util/libgnunetutil.la 458 $(top_builddir)/src/util/libgnunetutil.la
459endif
454 460
455test_namestore_api_zone_iteration_sqlite_SOURCES = \ 461test_namestore_api_zone_iteration_sqlite_SOURCES = \
456 test_namestore_api_zone_iteration.c 462 test_namestore_api_zone_iteration.c