aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am59
1 files changed, 36 insertions, 23 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 3dead06dc..5e7f1cbfd 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -17,29 +17,31 @@ if USE_COVERAGE
17endif 17endif
18 18
19 19
20#lib_LTLIBRARIES = \ 20check_PROGRAMS = \
21# libgnunetnamestore.la 21 test_namestore_api
22# 22
23#libgnunetnamestore_la_SOURCES = \ 23lib_LTLIBRARIES = \
24# namestore_api.c namestore.h 24 libgnunetnamestore.la
25#libgnunetnamestore_la_LIBADD = \ 25
26# $(top_builddir)/src/statistics/libgnunetstatistics.la \ 26libgnunetnamestore_la_SOURCES = \
27# $(top_builddir)/src/util/libgnunetutil.la \ 27 namestore_api.c namestore.h
28# $(GN_LIBINTL) 28libgnunetnamestore_la_LIBADD = \
29#libgnunetnamestore_la_LDFLAGS = \ 29 $(top_builddir)/src/statistics/libgnunetstatistics.la \
30# $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 30 $(top_builddir)/src/util/libgnunetutil.la \
31# -version-info 0:0:0 31 $(GN_LIBINTL)
32# 32libgnunetnamestore_la_LDFLAGS = \
33 33 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
34#bin_PROGRAMS = \ 34 -version-info 0:0:0
35# gnunet-service-namestore 35
36# 36bin_PROGRAMS = \
37#gnunet_service_namestore_SOURCES = \ 37 gnunet-service-namestore
38# gnunet-service-namestore.c 38
39#gnunet_service_namestore_LDADD = \ 39gnunet_service_namestore_SOURCES = \
40# $(top_builddir)/src/statistics/libgnunetstatistics.la \ 40 gnunet-service-namestore.c
41# $(top_builddir)/src/util/libgnunetutil.la \ 41gnunet_service_namestore_LDADD = \
42# $(GN_LIBINTL) 42 $(top_builddir)/src/statistics/libgnunetstatistics.la \
43 $(top_builddir)/src/util/libgnunetutil.la \
44 $(GN_LIBINTL)
43 45
44if HAVE_SQLITE 46if HAVE_SQLITE
45 SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la 47 SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
@@ -56,3 +58,14 @@ libgnunet_plugin_namestore_sqlite_la_LIBADD = \
56libgnunet_plugin_namestore_sqlite_la_LDFLAGS = \ 58libgnunet_plugin_namestore_sqlite_la_LDFLAGS = \
57 $(GN_PLUGIN_LDFLAGS) 59 $(GN_PLUGIN_LDFLAGS)
58 60
61
62test_namestore_api_SOURCES = \
63 test_namestore_api.c
64test_namestore_api_LDADD = \
65 $(top_builddir)/src/util/libgnunetutil.la \
66 $(top_builddir)/src/namestore/libgnunetnamestore.la
67
68EXTRADIST = \
69 test_namestore_api.conf
70
71 \ No newline at end of file