aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am222
1 files changed, 21 insertions, 201 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 51708dd67..32f2605ca 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -15,26 +15,6 @@ if USE_COVERAGE
15 XLIBS = -lgcov 15 XLIBS = -lgcov
16endif 16endif
17 17
18HEAP_PLUGIN = libgnunet_plugin_namestore_flat.la
19HEAP_TESTS = test_plugin_namestore_flat \
20 test_namestore_api_store_flat \
21 test_namestore_api_store_update_flat \
22 test_namestore_api_remove_flat \
23 test_namestore_api_zone_iteration_flat \
24 test_namestore_api_lookup_nick_flat \
25 test_namestore_api_monitoring_flat \
26 test_namestore_api_lookup_public_flat \
27 test_namestore_api_lookup_private_flat \
28 test_namestore_api_lookup_shadow_flat \
29 test_namestore_api_lookup_shadow_filter_flat \
30 test_namestore_api_remove_not_existing_record_flat \
31 test_namestore_api_zone_iteration_nick_flat \
32 test_namestore_api_zone_iteration_specific_zone_flat \
33 test_namestore_api_zone_iteration_stop_flat \
34 test_namestore_api_monitoring_existing_flat \
35 test_namestore_api_zone_to_name_flat \
36 perf_namestore_api_zone_iteration_flat
37
38if HAVE_SQLITE 18if HAVE_SQLITE
39SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la 19SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
40SQLITE_TESTS = test_plugin_namestore_sqlite \ 20SQLITE_TESTS = test_plugin_namestore_sqlite \
@@ -54,7 +34,8 @@ SQLITE_TESTS = test_plugin_namestore_sqlite \
54 test_namestore_api_zone_iteration_stop_sqlite \ 34 test_namestore_api_zone_iteration_stop_sqlite \
55 test_namestore_api_monitoring_existing_sqlite \ 35 test_namestore_api_monitoring_existing_sqlite \
56 test_namestore_api_zone_to_name_sqlite \ 36 test_namestore_api_zone_to_name_sqlite \
57 perf_namestore_api_zone_iteration_sqlite 37 perf_namestore_api_zone_iteration_sqlite \
38 test_namestore_api_tx_rollback_sqlite
58endif 39endif
59 40
60if HAVE_POSTGRESQL 41if HAVE_POSTGRESQL
@@ -76,14 +57,14 @@ POSTGRES_TESTS = test_plugin_namestore_postgres \
76 test_namestore_api_zone_iteration_stop_postgres \ 57 test_namestore_api_zone_iteration_stop_postgres \
77 test_namestore_api_monitoring_existing_postgres \ 58 test_namestore_api_monitoring_existing_postgres \
78 test_namestore_api_zone_to_name_postgres \ 59 test_namestore_api_zone_to_name_postgres \
79 perf_namestore_api_zone_iteration_postgres 60 perf_namestore_api_zone_iteration_postgres \
61 test_namestore_api_tx_rollback_postgres
80endif 62endif
81 63
82if HAVE_SQLITE 64if HAVE_SQLITE
83check_PROGRAMS = \ 65check_PROGRAMS = \
84 $(SQLITE_TESTS) \ 66 $(SQLITE_TESTS) \
85 $(POSTGRES_TESTS) \ 67 $(POSTGRES_TESTS)
86 $(HEAP_TESTS)
87endif 68endif
88 69
89if ENABLE_TEST_RUN 70if ENABLE_TEST_RUN
@@ -113,7 +94,6 @@ libexec_PROGRAMS += \
113plugin_LTLIBRARIES = \ 94plugin_LTLIBRARIES = \
114 $(SQLITE_PLUGIN) \ 95 $(SQLITE_PLUGIN) \
115 $(POSTGRES_PLUGIN) \ 96 $(POSTGRES_PLUGIN) \
116 $(HEAP_PLUGIN) \
117 $(REST_PLUGIN) 97 $(REST_PLUGIN)
118 98
119 99
@@ -195,18 +175,6 @@ gnunet_service_namestore_LDADD = \
195 175
196 176
197 177
198libgnunet_plugin_namestore_flat_la_SOURCES = \
199 plugin_namestore_flat.c
200libgnunet_plugin_namestore_flat_la_LIBADD = \
201 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
202 $(top_builddir)/src/identity/libgnunetidentity.la \
203 $(top_builddir)/src/statistics/libgnunetstatistics.la \
204 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
205 $(LTLIBINTL)
206libgnunet_plugin_namestore_flat_la_LDFLAGS = \
207 $(GN_PLUGIN_LDFLAGS)
208
209
210libgnunet_plugin_namestore_sqlite_la_SOURCES = \ 178libgnunet_plugin_namestore_sqlite_la_SOURCES = \
211 plugin_namestore_sqlite.c 179 plugin_namestore_sqlite.c
212libgnunet_plugin_namestore_sqlite_la_LIBADD = \ 180libgnunet_plugin_namestore_sqlite_la_LIBADD = \
@@ -231,15 +199,6 @@ libgnunet_plugin_namestore_postgres_la_LIBADD = \
231libgnunet_plugin_namestore_postgres_la_LDFLAGS = \ 199libgnunet_plugin_namestore_postgres_la_LDFLAGS = \
232 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS) 200 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
233 201
234test_namestore_api_store_flat_SOURCES = \
235 test_namestore_api_store.c
236test_namestore_api_store_flat_LDADD = \
237 $(top_builddir)/src/testing/libgnunettesting.la \
238 $(top_builddir)/src/util/libgnunetutil.la \
239 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
240 $(top_builddir)/src/identity/libgnunetidentity.la \
241 libgnunetnamestore.la
242
243test_namestore_api_store_sqlite_SOURCES = \ 202test_namestore_api_store_sqlite_SOURCES = \
244 test_namestore_api_store.c 203 test_namestore_api_store.c
245test_namestore_api_store_sqlite_LDADD = \ 204test_namestore_api_store_sqlite_LDADD = \
@@ -258,16 +217,6 @@ test_namestore_api_store_postgres_LDADD = \
258 $(top_builddir)/src/identity/libgnunetidentity.la \ 217 $(top_builddir)/src/identity/libgnunetidentity.la \
259 libgnunetnamestore.la 218 libgnunetnamestore.la
260 219
261test_namestore_api_store_update_flat_SOURCES = \
262 test_namestore_api_store_update.c
263test_namestore_api_store_update_flat_LDADD = \
264 $(top_builddir)/src/testing/libgnunettesting.la \
265 $(top_builddir)/src/util/libgnunetutil.la \
266 $(top_builddir)/src/identity/libgnunetidentity.la \
267 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
268 $(top_builddir)/src/namecache/libgnunetnamecache.la \
269 libgnunetnamestore.la
270
271test_namestore_api_store_update_sqlite_SOURCES = \ 220test_namestore_api_store_update_sqlite_SOURCES = \
272 test_namestore_api_store_update.c 221 test_namestore_api_store_update.c
273test_namestore_api_store_update_sqlite_LDADD = \ 222test_namestore_api_store_update_sqlite_LDADD = \
@@ -288,16 +237,6 @@ test_namestore_api_store_update_postgres_LDADD = \
288 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 237 $(top_builddir)/src/namecache/libgnunetnamecache.la \
289 libgnunetnamestore.la 238 libgnunetnamestore.la
290 239
291test_namestore_api_lookup_public_flat_SOURCES = \
292 test_namestore_api_lookup_public.c
293test_namestore_api_lookup_public_flat_LDADD = \
294 $(top_builddir)/src/testing/libgnunettesting.la \
295 $(top_builddir)/src/identity/libgnunetidentity.la \
296 $(top_builddir)/src/util/libgnunetutil.la \
297 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
298 $(top_builddir)/src/namecache/libgnunetnamecache.la \
299 libgnunetnamestore.la
300
301test_namestore_api_lookup_public_sqlite_SOURCES = \ 240test_namestore_api_lookup_public_sqlite_SOURCES = \
302 test_namestore_api_lookup_public.c 241 test_namestore_api_lookup_public.c
303test_namestore_api_lookup_public_sqlite_LDADD = \ 242test_namestore_api_lookup_public_sqlite_LDADD = \
@@ -338,26 +277,6 @@ test_namestore_api_lookup_nick_postgres_LDADD = \
338 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 277 $(top_builddir)/src/namecache/libgnunetnamecache.la \
339 libgnunetnamestore.la 278 libgnunetnamestore.la
340 279
341test_namestore_api_lookup_nick_flat_SOURCES = \
342 test_namestore_api_lookup_nick.c
343test_namestore_api_lookup_nick_flat_LDADD = \
344 $(top_builddir)/src/testing/libgnunettesting.la \
345 $(top_builddir)/src/identity/libgnunetidentity.la \
346 $(top_builddir)/src/util/libgnunetutil.la \
347 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
348 $(top_builddir)/src/namecache/libgnunetnamecache.la \
349 libgnunetnamestore.la
350
351test_namestore_api_lookup_private_flat_SOURCES = \
352 test_namestore_api_lookup_private.c
353test_namestore_api_lookup_private_flat_LDADD = \
354 $(top_builddir)/src/testing/libgnunettesting.la \
355 $(top_builddir)/src/identity/libgnunetidentity.la \
356 $(top_builddir)/src/util/libgnunetutil.la \
357 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
358 $(top_builddir)/src/namecache/libgnunetnamecache.la \
359 libgnunetnamestore.la
360
361test_namestore_api_lookup_private_sqlite_SOURCES = \ 280test_namestore_api_lookup_private_sqlite_SOURCES = \
362 test_namestore_api_lookup_private.c 281 test_namestore_api_lookup_private.c
363test_namestore_api_lookup_private_sqlite_LDADD = \ 282test_namestore_api_lookup_private_sqlite_LDADD = \
@@ -378,16 +297,6 @@ test_namestore_api_lookup_private_postgres_LDADD = \
378 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 297 $(top_builddir)/src/namecache/libgnunetnamecache.la \
379 libgnunetnamestore.la 298 libgnunetnamestore.la
380 299
381test_namestore_api_lookup_shadow_flat_SOURCES = \
382 test_namestore_api_lookup_shadow.c
383test_namestore_api_lookup_shadow_flat_LDADD = \
384 $(top_builddir)/src/testing/libgnunettesting.la \
385 $(top_builddir)/src/identity/libgnunetidentity.la \
386 $(top_builddir)/src/util/libgnunetutil.la \
387 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
388 $(top_builddir)/src/namecache/libgnunetnamecache.la \
389 libgnunetnamestore.la
390
391test_namestore_api_lookup_shadow_sqlite_SOURCES = \ 300test_namestore_api_lookup_shadow_sqlite_SOURCES = \
392 test_namestore_api_lookup_shadow.c 301 test_namestore_api_lookup_shadow.c
393test_namestore_api_lookup_shadow_sqlite_LDADD = \ 302test_namestore_api_lookup_shadow_sqlite_LDADD = \
@@ -408,16 +317,6 @@ test_namestore_api_lookup_shadow_postgres_LDADD = \
408 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 317 $(top_builddir)/src/namecache/libgnunetnamecache.la \
409 libgnunetnamestore.la 318 libgnunetnamestore.la
410 319
411test_namestore_api_lookup_shadow_filter_flat_SOURCES = \
412 test_namestore_api_lookup_shadow_filter.c
413test_namestore_api_lookup_shadow_filter_flat_LDADD = \
414 $(top_builddir)/src/testing/libgnunettesting.la \
415 $(top_builddir)/src/util/libgnunetutil.la \
416 $(top_builddir)/src/identity/libgnunetidentity.la \
417 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
418 $(top_builddir)/src/namecache/libgnunetnamecache.la \
419 libgnunetnamestore.la
420
421test_namestore_api_lookup_shadow_filter_sqlite_SOURCES = \ 320test_namestore_api_lookup_shadow_filter_sqlite_SOURCES = \
422 test_namestore_api_lookup_shadow_filter.c 321 test_namestore_api_lookup_shadow_filter.c
423test_namestore_api_lookup_shadow_filter_sqlite_LDADD = \ 322test_namestore_api_lookup_shadow_filter_sqlite_LDADD = \
@@ -455,24 +354,6 @@ test_namestore_api_remove_postgres_LDADD = \
455 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 354 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
456 libgnunetnamestore.la 355 libgnunetnamestore.la
457 356
458test_namestore_api_remove_flat_SOURCES = \
459 test_namestore_api_remove.c
460test_namestore_api_remove_flat_LDADD = \
461 $(top_builddir)/src/testing/libgnunettesting.la \
462 $(top_builddir)/src/identity/libgnunetidentity.la \
463 $(top_builddir)/src/util/libgnunetutil.la \
464 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
465 libgnunetnamestore.la
466
467test_namestore_api_remove_not_existing_record_flat_SOURCES = \
468 test_namestore_api_remove_not_existing_record.c
469test_namestore_api_remove_not_existing_record_flat_LDADD = \
470 $(top_builddir)/src/testing/libgnunettesting.la \
471 $(top_builddir)/src/identity/libgnunetidentity.la \
472 $(top_builddir)/src/util/libgnunetutil.la \
473 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
474 libgnunetnamestore.la
475
476test_namestore_api_remove_not_existing_record_sqlite_SOURCES = \ 357test_namestore_api_remove_not_existing_record_sqlite_SOURCES = \
477 test_namestore_api_remove_not_existing_record.c 358 test_namestore_api_remove_not_existing_record.c
478test_namestore_api_remove_not_existing_record_sqlite_LDADD = \ 359test_namestore_api_remove_not_existing_record_sqlite_LDADD = \
@@ -491,14 +372,6 @@ test_namestore_api_remove_not_existing_record_postgres_LDADD = \
491 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 372 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
492 libgnunetnamestore.la 373 libgnunetnamestore.la
493 374
494test_namestore_api_zone_to_name_flat_SOURCES = \
495 test_namestore_api_zone_to_name.c
496test_namestore_api_zone_to_name_flat_LDADD = \
497 $(top_builddir)/src/identity/libgnunetidentity.la \
498 $(top_builddir)/src/testing/libgnunettesting.la \
499 $(top_builddir)/src/util/libgnunetutil.la \
500 libgnunetnamestore.la
501
502test_namestore_api_zone_to_name_sqlite_SOURCES = \ 375test_namestore_api_zone_to_name_sqlite_SOURCES = \
503 test_namestore_api_zone_to_name.c 376 test_namestore_api_zone_to_name.c
504test_namestore_api_zone_to_name_sqlite_LDADD = \ 377test_namestore_api_zone_to_name_sqlite_LDADD = \
@@ -515,15 +388,6 @@ test_namestore_api_zone_to_name_postgres_LDADD = \
515 $(top_builddir)/src/util/libgnunetutil.la \ 388 $(top_builddir)/src/util/libgnunetutil.la \
516 libgnunetnamestore.la 389 libgnunetnamestore.la
517 390
518test_namestore_api_monitoring_flat_SOURCES = \
519 test_namestore_api_monitoring.c
520test_namestore_api_monitoring_flat_LDADD = \
521 $(top_builddir)/src/testing/libgnunettesting.la \
522 libgnunetnamestore.la \
523 $(top_builddir)/src/identity/libgnunetidentity.la \
524 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
525 $(top_builddir)/src/util/libgnunetutil.la
526
527test_namestore_api_monitoring_sqlite_SOURCES = \ 391test_namestore_api_monitoring_sqlite_SOURCES = \
528 test_namestore_api_monitoring.c 392 test_namestore_api_monitoring.c
529test_namestore_api_monitoring_sqlite_LDADD = \ 393test_namestore_api_monitoring_sqlite_LDADD = \
@@ -542,15 +406,6 @@ test_namestore_api_monitoring_postgres_LDADD = \
542 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 406 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
543 $(top_builddir)/src/util/libgnunetutil.la 407 $(top_builddir)/src/util/libgnunetutil.la
544 408
545test_namestore_api_monitoring_existing_flat_SOURCES = \
546 test_namestore_api_monitoring_existing.c
547test_namestore_api_monitoring_existing_flat_LDADD = \
548 $(top_builddir)/src/testing/libgnunettesting.la \
549 $(top_builddir)/src/identity/libgnunetidentity.la \
550 libgnunetnamestore.la \
551 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
552 $(top_builddir)/src/util/libgnunetutil.la
553
554test_namestore_api_monitoring_existing_sqlite_SOURCES = \ 409test_namestore_api_monitoring_existing_sqlite_SOURCES = \
555 test_namestore_api_monitoring_existing.c 410 test_namestore_api_monitoring_existing.c
556test_namestore_api_monitoring_existing_sqlite_LDADD = \ 411test_namestore_api_monitoring_existing_sqlite_LDADD = \
@@ -569,14 +424,25 @@ test_namestore_api_monitoring_existing_postgres_LDADD = \
569 $(top_builddir)/src/identity/libgnunetidentity.la \ 424 $(top_builddir)/src/identity/libgnunetidentity.la \
570 $(top_builddir)/src/util/libgnunetutil.la 425 $(top_builddir)/src/util/libgnunetutil.la
571 426
572test_namestore_api_zone_iteration_flat_SOURCES = \ 427test_namestore_api_tx_rollback_sqlite_SOURCES = \
573 test_namestore_api_zone_iteration.c 428 test_namestore_api_tx_rollback.c
574test_namestore_api_zone_iteration_flat_LDADD = \ 429test_namestore_api_tx_rollback_sqlite_LDADD = \
575 $(top_builddir)/src/testing/libgnunettesting.la \ 430 $(top_builddir)/src/testing/libgnunettesting.la \
576 $(top_builddir)/src/identity/libgnunetidentity.la \ 431 $(top_builddir)/src/identity/libgnunetidentity.la \
577 $(top_builddir)/src/util/libgnunetutil.la \ 432 libgnunetnamestore.la \
578 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 433 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
579 libgnunetnamestore.la 434 $(top_builddir)/src/util/libgnunetutil.la
435
436test_namestore_api_tx_rollback_postgres_SOURCES = \
437 test_namestore_api_tx_rollback.c
438test_namestore_api_tx_rollback_postgres_LDADD = \
439 $(top_builddir)/src/testing/libgnunettesting.la \
440 $(top_builddir)/src/identity/libgnunetidentity.la \
441 libgnunetnamestore.la \
442 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
443 $(top_builddir)/src/util/libgnunetutil.la
444
445
580 446
581test_namestore_api_zone_iteration_sqlite_SOURCES = \ 447test_namestore_api_zone_iteration_sqlite_SOURCES = \
582 test_namestore_api_zone_iteration.c 448 test_namestore_api_zone_iteration.c
@@ -614,24 +480,6 @@ perf_namestore_api_zone_iteration_sqlite_LDADD = \
614 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 480 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
615 libgnunetnamestore.la 481 libgnunetnamestore.la
616 482
617perf_namestore_api_zone_iteration_flat_SOURCES = \
618 perf_namestore_api_zone_iteration.c
619perf_namestore_api_zone_iteration_flat_LDADD = \
620 $(top_builddir)/src/testing/libgnunettesting.la \
621 $(top_builddir)/src/identity/libgnunetidentity.la \
622 $(top_builddir)/src/util/libgnunetutil.la \
623 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
624 libgnunetnamestore.la
625
626test_namestore_api_zone_iteration_nick_flat_SOURCES = \
627 test_namestore_api_zone_iteration_nick.c
628test_namestore_api_zone_iteration_nick_flat_LDADD = \
629 $(top_builddir)/src/testing/libgnunettesting.la \
630 $(top_builddir)/src/util/libgnunetutil.la \
631 $(top_builddir)/src/identity/libgnunetidentity.la \
632 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
633 libgnunetnamestore.la
634
635test_namestore_api_zone_iteration_nick_sqlite_SOURCES = \ 483test_namestore_api_zone_iteration_nick_sqlite_SOURCES = \
636 test_namestore_api_zone_iteration_nick.c 484 test_namestore_api_zone_iteration_nick.c
637test_namestore_api_zone_iteration_nick_sqlite_LDADD = \ 485test_namestore_api_zone_iteration_nick_sqlite_LDADD = \
@@ -650,15 +498,6 @@ test_namestore_api_zone_iteration_nick_postgres_LDADD = \
650 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 498 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
651 libgnunetnamestore.la 499 libgnunetnamestore.la
652 500
653test_namestore_api_zone_iteration_specific_zone_flat_SOURCES = \
654 test_namestore_api_zone_iteration_specific_zone.c
655test_namestore_api_zone_iteration_specific_zone_flat_LDADD = \
656 $(top_builddir)/src/testing/libgnunettesting.la \
657 $(top_builddir)/src/identity/libgnunetidentity.la \
658 $(top_builddir)/src/util/libgnunetutil.la \
659 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
660 libgnunetnamestore.la
661
662test_namestore_api_zone_iteration_specific_zone_sqlite_SOURCES = \ 501test_namestore_api_zone_iteration_specific_zone_sqlite_SOURCES = \
663 test_namestore_api_zone_iteration_specific_zone.c 502 test_namestore_api_zone_iteration_specific_zone.c
664test_namestore_api_zone_iteration_specific_zone_sqlite_LDADD = \ 503test_namestore_api_zone_iteration_specific_zone_sqlite_LDADD = \
@@ -677,15 +516,6 @@ test_namestore_api_zone_iteration_specific_zone_postgres_LDADD = \
677 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 516 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
678 libgnunetnamestore.la 517 libgnunetnamestore.la
679 518
680test_namestore_api_zone_iteration_stop_flat_SOURCES = \
681 test_namestore_api_zone_iteration_stop.c
682test_namestore_api_zone_iteration_stop_flat_LDADD = \
683 $(top_builddir)/src/testing/libgnunettesting.la \
684 $(top_builddir)/src/identity/libgnunetidentity.la \
685 $(top_builddir)/src/util/libgnunetutil.la \
686 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
687 libgnunetnamestore.la
688
689test_namestore_api_zone_iteration_stop_sqlite_SOURCES = \ 519test_namestore_api_zone_iteration_stop_sqlite_SOURCES = \
690 test_namestore_api_zone_iteration_stop.c 520 test_namestore_api_zone_iteration_stop.c
691test_namestore_api_zone_iteration_stop_sqlite_LDADD = \ 521test_namestore_api_zone_iteration_stop_sqlite_LDADD = \
@@ -704,13 +534,6 @@ test_namestore_api_zone_iteration_stop_postgres_LDADD = \
704 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 534 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
705 libgnunetnamestore.la 535 libgnunetnamestore.la
706 536
707test_plugin_namestore_flat_SOURCES = \
708 test_plugin_namestore.c
709test_plugin_namestore_flat_LDADD = \
710 $(top_builddir)/src/testing/libgnunettesting.la \
711 $(top_builddir)/src/identity/libgnunetidentity.la \
712 $(top_builddir)/src/util/libgnunetutil.la
713
714test_plugin_namestore_sqlite_SOURCES = \ 537test_plugin_namestore_sqlite_SOURCES = \
715 test_plugin_namestore.c 538 test_plugin_namestore.c
716test_plugin_namestore_sqlite_LDADD = \ 539test_plugin_namestore_sqlite_LDADD = \
@@ -738,12 +561,9 @@ EXTRA_DIST = \
738 test_namestore_api.conf \ 561 test_namestore_api.conf \
739 test_namestore_api_postgres.conf \ 562 test_namestore_api_postgres.conf \
740 test_namestore_api_sqlite.conf \ 563 test_namestore_api_sqlite.conf \
741 test_namestore_api_flat.conf \
742 perf_namestore_api_postgres.conf \ 564 perf_namestore_api_postgres.conf \
743 perf_namestore_api_sqlite.conf \ 565 perf_namestore_api_sqlite.conf \
744 perf_namestore_api_flat.conf \
745 test_plugin_namestore_sqlite.conf \ 566 test_plugin_namestore_sqlite.conf \
746 test_plugin_namestore_postgres.conf \ 567 test_plugin_namestore_postgres.conf \
747 test_plugin_namestore_flat.conf \
748 test_hostkey \ 568 test_hostkey \
749 $(check_SCRIPTS) 569 $(check_SCRIPTS)