aboutsummaryrefslogtreecommitdiff
path: root/src/nat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/nat/Makefile.am')
-rw-r--r--src/nat/Makefile.am18
1 files changed, 7 insertions, 11 deletions
diff --git a/src/nat/Makefile.am b/src/nat/Makefile.am
index db104d194..63a11f1fe 100644
--- a/src/nat/Makefile.am
+++ b/src/nat/Makefile.am
@@ -12,15 +12,11 @@ if LINUX
12 NATBIN = gnunet-helper-nat-server gnunet-helper-nat-client 12 NATBIN = gnunet-helper-nat-server gnunet-helper-nat-client
13 NATSERVER = gnunet-helper-nat-server.c 13 NATSERVER = gnunet-helper-nat-server.c
14 NATCLIENT = gnunet-helper-nat-client.c 14 NATCLIENT = gnunet-helper-nat-client.c
15install-exec-hook:
16 $(top_srcdir)/src/nat/install-nat-helper.sh $(DESTDIR)$(libexecdir) $(SUDO_BINARY) || true
17else 15else
18if XFREEBSD 16if XFREEBSD
19 NATBIN = gnunet-helper-nat-server gnunet-helper-nat-client 17 NATBIN = gnunet-helper-nat-server gnunet-helper-nat-client
20 NATSERVER = gnunet-helper-nat-server.c 18 NATSERVER = gnunet-helper-nat-server.c
21 NATCLIENT = gnunet-helper-nat-client.c 19 NATCLIENT = gnunet-helper-nat-client.c
22install-exec-hook:
23 $(top_srcdir)/src/nat/install-nat-helper.sh $(DESTDIR)$(libexecdir) $(SUDO_BINARY) || true
24endif 20endif
25else 21else
26install-exec-hook: 22install-exec-hook:
@@ -53,7 +49,7 @@ if USE_COVERAGE
53endif 49endif
54 50
55lib_LTLIBRARIES = \ 51lib_LTLIBRARIES = \
56 libgnunetnatnew.la 52 libgnunetnatnew.la
57 53
58libgnunetnatnew_la_SOURCES = \ 54libgnunetnatnew_la_SOURCES = \
59 nat_api.c \ 55 nat_api.c \
@@ -61,9 +57,9 @@ libgnunetnatnew_la_SOURCES = \
61 nat.h 57 nat.h
62libgnunetnatnew_la_LIBADD = \ 58libgnunetnatnew_la_LIBADD = \
63 $(top_builddir)/src/util/libgnunetutil.la \ 59 $(top_builddir)/src/util/libgnunetutil.la \
64 $(GN_LIBINTL) @EXT_LIBS@ 60 $(GN_LIBINTL) @EXT_LIBS@
65libgnunetnatnew_la_LDFLAGS = \ 61libgnunetnatnew_la_LDFLAGS = \
66 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 62 $(GN_LIB_LDFLAGS) \
67 -version-info 2:0:0 63 -version-info 2:0:0
68 64
69gnunet_service_nat_SOURCES = \ 65gnunet_service_nat_SOURCES = \
@@ -94,25 +90,25 @@ endif
94# test_nat.c 90# test_nat.c
95#test_nat_LDADD = \ 91#test_nat_LDADD = \
96# libgnunetnat.la \ 92# libgnunetnat.la \
97# $(top_builddir)/src/util/libgnunetutil.la 93# $(top_builddir)/src/util/libgnunetutil.la
98 94
99#test_nat_mini_SOURCES = \ 95#test_nat_mini_SOURCES = \
100# test_nat_mini.c 96# test_nat_mini.c
101#test_nat_mini_LDADD = \ 97#test_nat_mini_LDADD = \
102# libgnunetnat.la \ 98# libgnunetnat.la \
103# $(top_builddir)/src/util/libgnunetutil.la 99# $(top_builddir)/src/util/libgnunetutil.la
104 100
105#test_nat_test_SOURCES = \ 101#test_nat_test_SOURCES = \
106# test_nat_test.c 102# test_nat_test.c
107#test_nat_test_LDADD = \ 103#test_nat_test_LDADD = \
108# libgnunetnat.la \ 104# libgnunetnat.la \
109# $(top_builddir)/src/util/libgnunetutil.la 105# $(top_builddir)/src/util/libgnunetutil.la
110 106
111#test_stun_SOURCES = \ 107#test_stun_SOURCES = \
112# test_stun.c 108# test_stun.c
113#test_stun_LDADD = \ 109#test_stun_LDADD = \
114# libgnunetnat.la \ 110# libgnunetnat.la \
115# $(top_builddir)/src/util/libgnunetutil.la 111# $(top_builddir)/src/util/libgnunetutil.la
116 112
117EXTRA_DIST = \ 113EXTRA_DIST = \
118 test_nat_data.conf \ 114 test_nat_data.conf \