aboutsummaryrefslogtreecommitdiff
path: root/src/nat/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/nat/meson.build')
-rw-r--r--src/nat/meson.build33
1 files changed, 21 insertions, 12 deletions
diff --git a/src/nat/meson.build b/src/nat/meson.build
index 23c2bb18d..e660f59be 100644
--- a/src/nat/meson.build
+++ b/src/nat/meson.build
@@ -15,19 +15,28 @@ configure_file(input : 'nat.conf.in',
15 install_dir: pkgcfgdir) 15 install_dir: pkgcfgdir)
16 16
17 17
18if get_option('monolith') == false 18if get_option('monolith')
19 libgnunetnat = library('gnunetnat',
20 libgnunetnat_src,
21 dependencies: libgnunetutil_dep,
22 include_directories: [incdir, configuration_inc])
23 libgnunetnat_dep = declare_dependency(link_with : libgnunetnat)
24 executable ('gnunet-service-nat',
25 gnunetservicenat_src,
26 dependencies: [libgnunetnat_dep, libgnunetutil_dep,
27 libgnunetstatistics_dep],
28 include_directories: [incdir, configuration_inc])
29else
30 foreach p : libgnunetnat_src + gnunetservicenat_src 19 foreach p : libgnunetnat_src + gnunetservicenat_src
31 gnunet_src += 'nat/' + p 20 gnunet_src += 'nat/' + p
32 endforeach 21 endforeach
22 subdir_done()
33endif 23endif
24
25libgnunetnat = library('gnunetnat',
26 libgnunetnat_src,
27 dependencies: libgnunetutil_dep,
28 include_directories: [incdir, configuration_inc],
29 install: true,
30 install_dir: get_option('libdir'))
31libgnunetnat_dep = declare_dependency(link_with : libgnunetnat)
32pkg.generate(libgnunetnat, url: 'https://www.gnunet.org',
33 description : 'Provides API for accessing the NAT service')
34
35executable ('gnunet-service-nat',
36 gnunetservicenat_src,
37 dependencies: [libgnunetnat_dep, libgnunetutil_dep,
38 libgnunetstatistics_dep],
39 include_directories: [incdir, configuration_inc],
40 install: true,
41 install_dir: get_option('libdir')/'gnunet'/'libexec')
42