aboutsummaryrefslogtreecommitdiff
path: root/src/nat/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/nat/meson.build')
-rw-r--r--src/nat/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/nat/meson.build b/src/nat/meson.build
index 415d6cbb3..e629f6411 100644
--- a/src/nat/meson.build
+++ b/src/nat/meson.build
@@ -33,6 +33,16 @@ libgnunetnat = library('gnunetnat',
33libgnunetnat_dep = declare_dependency(link_with : libgnunetnat) 33libgnunetnat_dep = declare_dependency(link_with : libgnunetnat)
34pkg.generate(libgnunetnat, url: 'https://www.gnunet.org', 34pkg.generate(libgnunetnat, url: 'https://www.gnunet.org',
35 description : 'Provides API for accessing the NAT service') 35 description : 'Provides API for accessing the NAT service')
36libgnunetnat = library('gnunetnatnew',
37 ['nat_api.c',
38 'nat_api_stun.c'],
39 soversion: '2',
40 version: '2.0.0',
41 dependencies: libgnunetutil_dep,
42 include_directories: [incdir, configuration_inc],
43 install: true,
44 install_dir: get_option('libdir'))
45libgnunetnat_dep = declare_dependency(link_with : libgnunetnat)
36 46
37executable ('gnunet-nat', 47executable ('gnunet-nat',
38 ['gnunet-nat.c'], 48 ['gnunet-nat.c'],