aboutsummaryrefslogtreecommitdiff
path: root/src/nse/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/nse/Makefile.am')
-rw-r--r--src/nse/Makefile.am106
1 files changed, 0 insertions, 106 deletions
diff --git a/src/nse/Makefile.am b/src/nse/Makefile.am
deleted file mode 100644
index 0c6182e61..000000000
--- a/src/nse/Makefile.am
+++ /dev/null
@@ -1,106 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9pkgcfgdir= $(pkgdatadir)/config.d/
10
11libexecdir= $(pkglibdir)/libexec/
12
13pkgcfg_DATA = \
14 nse.conf
15
16bin_PROGRAMS = gnunet-nse
17
18gnunet_nse_SOURCES = gnunet-nse.c
19gnunet_nse_LDADD = \
20 libgnunetnse.la \
21 $(top_builddir)/src/util/libgnunetutil.la \
22 $(XLIB) $(GN_LIBINTL)
23
24lib_LTLIBRARIES = libgnunetnse.la
25
26libgnunetnse_la_SOURCES = \
27 nse_api.c nse.h
28libgnunetnse_la_LIBADD = \
29 $(top_builddir)/src/util/libgnunetutil.la \
30 $(GN_LIBINTL) $(XLIB)
31libgnunetnse_la_LDFLAGS = \
32 $(GN_LIB_LDFLAGS) \
33 -version-info 0:0:0
34
35
36libexec_PROGRAMS = \
37 gnunet-service-nse
38
39noinst_PROGRAMS = \
40 gnunet-nse-profiler
41
42gnunet_nse_profiler_SOURCES = \
43 gnunet-nse-profiler.c
44gnunet_nse_profiler_LDADD = -lm \
45 libgnunetnse.la \
46 $(top_builddir)/src/util/libgnunetutil.la \
47 $(top_builddir)/src/statistics/libgnunetstatistics.la \
48 $(top_builddir)/src/testing/libgnunettesting.la \
49 $(top_builddir)/src/testbed/libgnunettestbed.la \
50 $(GN_LIBINTL)
51
52gnunet_service_nse_SOURCES = \
53 gnunet-service-nse.c
54gnunet_service_nse_LDADD = \
55 libgnunetnse.la \
56 $(top_builddir)/src/util/libgnunetutil.la \
57 $(top_builddir)/src/core/libgnunetcore.la \
58 $(top_builddir)/src/statistics/libgnunetstatistics.la \
59 $(LIBGCRYPT_LIBS) \
60 -lm -lgcrypt \
61 $(GN_LIBINTL)
62if ENABLE_NSE_HISTOGRAM
63 gnunet_service_nse_LDADD += \
64 $(top_builddir)/src/testbed-logger/libgnunettestbedlogger.la
65endif
66
67
68if HAVE_BENCHMARKS
69 MULTIPEER_TEST = test_nse_multipeer
70endif
71
72check_PROGRAMS = \
73 test_nse_api \
74 perf_kdf \
75 $(MULTIPEER_TEST)
76
77if ENABLE_TEST_RUN
78AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
79TESTS = $(check_PROGRAMS)
80endif
81
82test_nse_api_SOURCES = \
83 test_nse_api.c
84test_nse_api_LDADD = \
85 libgnunetnse.la \
86 $(top_builddir)/src/testing/libgnunettesting.la \
87 $(top_builddir)/src/util/libgnunetutil.la
88
89test_nse_multipeer_SOURCES = \
90 test_nse_multipeer.c
91test_nse_multipeer_LDADD = \
92 libgnunetnse.la \
93 $(top_builddir)/src/util/libgnunetutil.la \
94 $(top_builddir)/src/testbed/libgnunettestbed.la \
95 -lm
96
97perf_kdf_SOURCES = \
98 perf_kdf.c
99perf_kdf_LDADD = \
100 $(top_builddir)/src/util/libgnunetutil.la \
101 $(LIBGCRYPT_LIBS) \
102 -lgcrypt
103
104EXTRA_DIST = \
105 test_nse.conf \
106 nse_profiler_test.conf