aboutsummaryrefslogtreecommitdiff
path: root/src/peerinfo-tool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/peerinfo-tool/Makefile.am')
-rw-r--r--src/peerinfo-tool/Makefile.am64
1 files changed, 0 insertions, 64 deletions
diff --git a/src/peerinfo-tool/Makefile.am b/src/peerinfo-tool/Makefile.am
deleted file mode 100644
index 825ad5452..000000000
--- a/src/peerinfo-tool/Makefile.am
+++ /dev/null
@@ -1,64 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9REST_PLUGIN = libgnunet_plugin_rest_peerinfo.la
10
11plugindir = $(libdir)/gnunet
12
13plugin_LTLIBRARIES = $(REST_PLUGIN)
14
15bin_PROGRAMS = \
16 gnunet-peerinfo
17
18libgnunet_plugin_rest_peerinfo_la_SOURCES = \
19 plugin_rest_peerinfo.c
20libgnunet_plugin_rest_peerinfo_la_LIBADD = \
21 $(top_builddir)/src/hello/libgnunethello.la \
22 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
23 $(top_builddir)/src/transport/libgnunettransport.la \
24 $(top_builddir)/src/ats/libgnunetats.la \
25 $(top_builddir)/src/rest/libgnunetrest.la \
26 $(top_builddir)/src/json/libgnunetjson.la \
27 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
28 $(LTLIBINTL) -ljansson $(MHD_LIBS)
29libgnunet_plugin_rest_peerinfo_la_LDFLAGS = \
30 $(GN_PLUGIN_LDFLAGS)
31libgnunet_plugin_rest_peerinfo_la_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
32
33
34gnunet_peerinfo_SOURCES = \
35 gnunet-peerinfo.c \
36 gnunet-peerinfo_plugins.c gnunet-peerinfo_plugins.h
37gnunet_peerinfo_LDADD = \
38 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
39 $(top_builddir)/src/transport/libgnunettransport.la \
40 $(top_builddir)/src/hello/libgnunethello.la \
41 $(top_builddir)/src/statistics/libgnunetstatistics.la \
42 $(top_builddir)/src/util/libgnunetutil.la
43gnunet_peerinfo_LDFLAGS = \
44 $(GN_LIBINTL)
45
46if HAVE_PYTHON
47check_SCRIPTS = \
48 test_gnunet_peerinfo.py
49endif
50
51if ENABLE_TEST_RUN
52AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
53TESTS = $(check_SCRIPTS)
54endif
55
56test_gnunet_peerinfo.py: test_gnunet_peerinfo.py.in Makefile
57 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/test_gnunet_peerinfo.py.in > test_gnunet_peerinfo.py
58 chmod +x test_gnunet_peerinfo.py
59
60EXTRA_DIST = \
61 test_gnunet_peerinfo.py.in \
62 test_gnunet_peerinfo_data.conf
63
64CLEANFILES = $(check_SCRIPTS)