aboutsummaryrefslogtreecommitdiff
path: root/src/peerinfo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/peerinfo/Makefile.am')
-rw-r--r--src/peerinfo/Makefile.am105
1 files changed, 0 insertions, 105 deletions
diff --git a/src/peerinfo/Makefile.am b/src/peerinfo/Makefile.am
deleted file mode 100644
index cdab22a9d..000000000
--- a/src/peerinfo/Makefile.am
+++ /dev/null
@@ -1,105 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8plugindir = $(libdir)/gnunet
9
10pkgcfg_DATA = \
11 peerinfo.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = --coverage -O0
15 XLIB = -lgcov
16endif
17
18lib_LTLIBRARIES = libgnunetpeerinfo.la
19
20
21libgnunetpeerinfo_la_SOURCES = \
22 peerinfo_api.c peerinfo.h \
23 peerinfo_api_notify.c
24libgnunetpeerinfo_la_LIBADD = \
25 $(top_builddir)/src/hello/libgnunethello.la \
26 $(top_builddir)/src/util/libgnunetutil.la \
27 $(XLIB) \
28 $(LTLIBINTL)
29libgnunetpeerinfo_la_LDFLAGS = \
30 $(GN_LIB_LDFLAGS) \
31 -version-info 0:0:0
32
33
34libexec_PROGRAMS = \
35 gnunet-service-peerinfo
36
37gnunet_service_peerinfo_SOURCES = \
38 gnunet-service-peerinfo.c
39gnunet_service_peerinfo_LDADD = \
40 $(top_builddir)/src/hello/libgnunethello.la \
41 $(top_builddir)/src/statistics/libgnunetstatistics.la \
42 $(top_builddir)/src/util/libgnunetutil.la
43gnunet_service_peerinfo_LDFLAGS = \
44 $(GN_LIBINTL)
45
46if HAVE_BENCHMARKS
47 PEERINFO_BENCHMARKS = \
48 perf_peerinfo_api
49endif
50
51check_PROGRAMS = \
52 test_peerinfo_shipped_hellos \
53 test_peerinfo_api \
54 test_peerinfo_api_friend_only \
55 test_peerinfo_api_notify_friend_only \
56 $(PEERINFO_BENCHMARKS)
57
58
59if ENABLE_TEST_RUN
60AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
61TESTS = $(check_PROGRAMS)
62endif
63
64test_peerinfo_shipped_hellos_SOURCES = \
65 test_peerinfo_shipped_hellos.c
66test_peerinfo_shipped_hellos_LDADD = \
67 $(top_builddir)/src/hello/libgnunethello.la \
68 libgnunetpeerinfo.la \
69 $(top_builddir)/src/testing/libgnunettesting.la \
70 $(top_builddir)/src/util/libgnunetutil.la
71
72test_peerinfo_api_SOURCES = \
73 test_peerinfo_api.c
74test_peerinfo_api_LDADD = \
75 $(top_builddir)/src/hello/libgnunethello.la \
76 libgnunetpeerinfo.la \
77 $(top_builddir)/src/testing/libgnunettesting.la \
78 $(top_builddir)/src/util/libgnunetutil.la
79
80test_peerinfo_api_friend_only_SOURCES = \
81 test_peerinfo_api_friend_only.c
82test_peerinfo_api_friend_only_LDADD = \
83 $(top_builddir)/src/hello/libgnunethello.la \
84 libgnunetpeerinfo.la \
85 $(top_builddir)/src/testing/libgnunettesting.la \
86 $(top_builddir)/src/util/libgnunetutil.la
87
88test_peerinfo_api_notify_friend_only_SOURCES = \
89 test_peerinfo_api_notify_friend_only.c
90test_peerinfo_api_notify_friend_only_LDADD = \
91 $(top_builddir)/src/hello/libgnunethello.la \
92 libgnunetpeerinfo.la \
93 $(top_builddir)/src/testing/libgnunettesting.la \
94 $(top_builddir)/src/util/libgnunetutil.la
95
96perf_peerinfo_api_SOURCES = \
97 perf_peerinfo_api.c
98perf_peerinfo_api_LDADD = \
99 $(top_builddir)/src/hello/libgnunethello.la \
100 libgnunetpeerinfo.la \
101 $(top_builddir)/src/testing/libgnunettesting.la \
102 $(top_builddir)/src/util/libgnunetutil.la
103
104EXTRA_DIST = \
105 test_peerinfo_api_data.conf