aboutsummaryrefslogtreecommitdiff
path: root/src/peerstore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/peerstore/Makefile.am')
-rw-r--r--src/peerstore/Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/src/peerstore/Makefile.am b/src/peerstore/Makefile.am
new file mode 100644
index 000000000..0b111cc50
--- /dev/null
+++ b/src/peerstore/Makefile.am
@@ -0,0 +1,59 @@
1AM_CPPFLAGS = -I$(top_srcdir)/src/include
2
3pkgcfgdir= $(pkgdatadir)/config.d/
4
5libexecdir= $(pkglibdir)/libexec/
6
7dist_pkgcfg_DATA = \
8 peerstore.conf
9
10if MINGW
11 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
12endif
13
14if USE_COVERAGE
15 AM_CFLAGS = -fprofile-arcs -ftest-coverage
16endif
17
18bin_PROGRAMS = \
19 gnunet-peerstore
20
21libexec_PROGRAMS = \
22 gnunet-service-peerstore
23
24lib_LTLIBRARIES = \
25 libgnunetpeerstore.la
26
27gnunet_peerstore_SOURCES = \
28 gnunet-peerstore.c
29gnunet_peerstore_LDADD = \
30 $(top_builddir)/src/util/libgnunetutil.la \
31 libgnunetpeerstore.la \
32 $(GN_LIBINTL)
33
34gnunet_service_peerstore_SOURCES = \
35 gnunet-service-peerstore.c
36gnunet_service_peerstore_LDADD = \
37 $(top_builddir)/src/util/libgnunetutil.la \
38 $(GN_LIBINTL)
39
40libgnunetpeerstore_la_SOURCES = \
41 peerstore_api.c
42libgnunetpeerstore_la_LIBADD = \
43 $(top_builddir)/src/util/libgnunetutil.la
44libgnunetpeerstore_la_LDFLAGS = \
45 $(GNUNET_LDFLAGS)
46
47check_PROGRAMS = \
48 test_peerstore_api
49
50if ENABLE_TEST_RUN
51AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
52TESTS = $(check_PROGRAMS)
53endif
54
55test_peerstore_api_SOURCES = \
56 test_peerstore_api.c
57test_peerstore_api_LDADD = \
58 $(top_builddir)/src/util/libgnunetutil.la
59