aboutsummaryrefslogtreecommitdiff
path: root/src/peerstore/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/peerstore/meson.build')
-rw-r--r--src/peerstore/meson.build31
1 files changed, 20 insertions, 11 deletions
diff --git a/src/peerstore/meson.build b/src/peerstore/meson.build
index f5727411c..d93042876 100644
--- a/src/peerstore/meson.build
+++ b/src/peerstore/meson.build
@@ -10,18 +10,27 @@ configure_file(input : 'peerstore.conf.in',
10 install_dir: pkgcfgdir) 10 install_dir: pkgcfgdir)
11 11
12 12
13if get_option('monolith') == false 13if get_option('monolith')
14 libgnunetpeerstore = library('gnunetpeerstore',
15 libgnunetpeerstore_src,
16 dependencies: libgnunetutil_dep,
17 include_directories: [incdir, configuration_inc])
18 libgnunetpeerstore_dep = declare_dependency(link_with : libgnunetpeerstore)
19 executable ('gnunet-service-peerstore',
20 gnunetservicepeerstore_src,
21 dependencies: [libgnunetpeerstore_dep, libgnunetutil_dep],
22 include_directories: [incdir, configuration_inc])
23else
24 foreach p : libgnunetpeerstore_src + gnunetservicepeerstore_src 14 foreach p : libgnunetpeerstore_src + gnunetservicepeerstore_src
25 gnunet_src += 'peerstore/' + p 15 gnunet_src += 'peerstore/' + p
26 endforeach 16 endforeach
17 subdir_done()
27endif 18endif
19
20libgnunetpeerstore = library('gnunetpeerstore',
21 libgnunetpeerstore_src,
22 dependencies: libgnunetutil_dep,
23 include_directories: [incdir, configuration_inc],
24 install: true,
25 install_dir: get_option('libdir'))
26pkg.generate(libgnunetpeerstore, url: 'https://www.gnunet.org',
27 description : 'Provides API for accessing the peerstore service')
28libgnunetpeerstore_dep = declare_dependency(link_with : libgnunetpeerstore)
29
30executable ('gnunet-service-peerstore',
31 gnunetservicepeerstore_src,
32 dependencies: [libgnunetpeerstore_dep, libgnunetutil_dep],
33 include_directories: [incdir, configuration_inc],
34 install: true,
35 install_dir: get_option('libdir') / 'gnunet' / 'libexec')
36