aboutsummaryrefslogtreecommitdiff
path: root/src/plugin/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugin/namestore/Makefile.am')
-rw-r--r--src/plugin/namestore/Makefile.am360
1 files changed, 14 insertions, 346 deletions
diff --git a/src/plugin/namestore/Makefile.am b/src/plugin/namestore/Makefile.am
index 03b743d7a..3db174225 100644
--- a/src/plugin/namestore/Makefile.am
+++ b/src/plugin/namestore/Makefile.am
@@ -19,62 +19,7 @@ if USE_COVERAGE
19endif 19endif
20 20
21 21
22if HAVE_SQLITE
23SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
24SQLITE_TESTS = test_plugin_namestore_sqlite \
25 test_namestore_api_store_sqlite \
26 test_namestore_api_store_update_sqlite \
27 test_namestore_api_zone_iteration_sqlite \
28 test_namestore_api_remove_sqlite \
29 test_namestore_api_lookup_nick_sqlite \
30 test_namestore_api_monitoring_sqlite \
31 test_namestore_api_remove_not_existing_record_sqlite \
32 test_namestore_api_zone_iteration_nick_sqlite \
33 test_namestore_api_zone_iteration_specific_zone_sqlite \
34 test_namestore_api_zone_iteration_stop_sqlite \
35 test_namestore_api_monitoring_existing_sqlite \
36 test_namestore_api_zone_to_name_sqlite \
37 perf_namestore_api_zone_iteration_sqlite \
38 perf_namestore_api_import_sqlite \
39 perf_namestore_api_import_postgres \
40 test_namestore_api_tx_rollback_sqlite
41endif
42
43
44if HAVE_POSTGRESQL
45POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
46POSTGRES_TESTS = test_plugin_namestore_postgres \
47 test_namestore_api_store_postgres \
48 test_namestore_api_store_update_postgres \
49 test_namestore_api_remove_postgres \
50 test_namestore_api_zone_iteration_postgres \
51 test_namestore_api_lookup_nick_postgres \
52 test_namestore_api_monitoring_postgres \
53 test_namestore_api_remove_not_existing_record_postgres \
54 test_namestore_api_zone_iteration_nick_postgres \
55 test_namestore_api_zone_iteration_specific_zone_postgres \
56 test_namestore_api_zone_iteration_stop_postgres \
57 test_namestore_api_monitoring_existing_postgres \
58 test_namestore_api_zone_to_name_postgres \
59 perf_namestore_api_zone_iteration_postgres \
60 test_namestore_api_tx_rollback_postgres
61if HAVE_EXPERIMENTAL
62POSTGRES_TESTS += test_namestore_api_edit_records_postgres
63endif
64endif
65
66if HAVE_SQLITE
67check_PROGRAMS = \
68 $(SQLITE_TESTS) \
69 $(POSTGRES_TESTS)
70endif
71 22
72if ENABLE_TEST_RUN
73AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
74TESTS = \
75 $(check_PROGRAMS) \
76 $(check_SCRIPTS)
77endif
78 23
79plugin_LTLIBRARIES = \ 24plugin_LTLIBRARIES = \
80 $(SQLITE_PLUGIN) \ 25 $(SQLITE_PLUGIN) \
@@ -101,311 +46,34 @@ libgnunet_plugin_namestore_postgres_la_LIBADD = \
101libgnunet_plugin_namestore_postgres_la_LDFLAGS = \ 46libgnunet_plugin_namestore_postgres_la_LDFLAGS = \
102 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS) 47 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
103 48
104test_namestore_api_store_sqlite_SOURCES = \ 49if HAVE_SQLITE
105 test_namestore_api_store.c 50SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
106test_namestore_api_store_sqlite_LDADD = \ 51SQLITE_TESTS = test_plugin_namestore_sqlite
107 $(top_builddir)/src/service/testing/libgnunettesting.la \
108 $(top_builddir)/src/lib/util/libgnunetutil.la \
109 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
110 $(top_builddir)/src/service/identity/libgnunetidentity.la \
111 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
112
113test_namestore_api_store_postgres_SOURCES = \
114 test_namestore_api_store.c
115test_namestore_api_store_postgres_LDADD = \
116 $(top_builddir)/src/service/testing/libgnunettesting.la \
117 $(top_builddir)/src/lib/util/libgnunetutil.la \
118 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
119 $(top_builddir)/src/service/identity/libgnunetidentity.la \
120 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
121
122test_namestore_api_store_update_sqlite_SOURCES = \
123 test_namestore_api_store_update.c
124test_namestore_api_store_update_sqlite_LDADD = \
125 $(top_builddir)/src/service/testing/libgnunettesting.la \
126 $(top_builddir)/src/lib/util/libgnunetutil.la \
127 $(top_builddir)/src/service/identity/libgnunetidentity.la \
128 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
129 $(top_builddir)/src/service/namecache/libgnunetnamecache.la \
130 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
131
132test_namestore_api_store_update_postgres_SOURCES = \
133 test_namestore_api_store_update.c
134test_namestore_api_store_update_postgres_LDADD = \
135 $(top_builddir)/src/service/testing/libgnunettesting.la \
136 $(top_builddir)/src/lib/util/libgnunetutil.la \
137 $(top_builddir)/src/service/identity/libgnunetidentity.la \
138 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
139 $(top_builddir)/src/service/namecache/libgnunetnamecache.la \
140 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
141
142test_namestore_api_lookup_nick_sqlite_SOURCES = \
143 test_namestore_api_lookup_nick.c
144test_namestore_api_lookup_nick_sqlite_LDADD = \
145 $(top_builddir)/src/service/testing/libgnunettesting.la \
146 $(top_builddir)/src/lib/util/libgnunetutil.la \
147 $(top_builddir)/src/service/identity/libgnunetidentity.la \
148 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
149 $(top_builddir)/src/service/namecache/libgnunetnamecache.la \
150 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
151
152test_namestore_api_lookup_nick_postgres_SOURCES = \
153 test_namestore_api_lookup_nick.c
154test_namestore_api_lookup_nick_postgres_LDADD = \
155 $(top_builddir)/src/service/testing/libgnunettesting.la \
156 $(top_builddir)/src/lib/util/libgnunetutil.la \
157 $(top_builddir)/src/service/identity/libgnunetidentity.la \
158 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
159 $(top_builddir)/src/service/namecache/libgnunetnamecache.la \
160 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
161
162test_namestore_api_remove_sqlite_SOURCES = \
163 test_namestore_api_remove.c
164test_namestore_api_remove_sqlite_LDADD = \
165 $(top_builddir)/src/service/identity/libgnunetidentity.la \
166 $(top_builddir)/src/service/testing/libgnunettesting.la \
167 $(top_builddir)/src/lib/util/libgnunetutil.la \
168 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
169 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
170
171test_namestore_api_remove_postgres_SOURCES = \
172 test_namestore_api_remove.c
173test_namestore_api_remove_postgres_LDADD = \
174 $(top_builddir)/src/service/identity/libgnunetidentity.la \
175 $(top_builddir)/src/service/testing/libgnunettesting.la \
176 $(top_builddir)/src/lib/util/libgnunetutil.la \
177 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
178 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
179
180test_namestore_api_remove_not_existing_record_sqlite_SOURCES = \
181 test_namestore_api_remove_not_existing_record.c
182test_namestore_api_remove_not_existing_record_sqlite_LDADD = \
183 $(top_builddir)/src/service/testing/libgnunettesting.la \
184 $(top_builddir)/src/lib/util/libgnunetutil.la \
185 $(top_builddir)/src/service/identity/libgnunetidentity.la \
186 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
187 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
188
189test_namestore_api_remove_not_existing_record_postgres_SOURCES = \
190 test_namestore_api_remove_not_existing_record.c
191test_namestore_api_remove_not_existing_record_postgres_LDADD = \
192 $(top_builddir)/src/service/testing/libgnunettesting.la \
193 $(top_builddir)/src/service/identity/libgnunetidentity.la \
194 $(top_builddir)/src/lib/util/libgnunetutil.la \
195 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
196 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
197
198test_namestore_api_zone_to_name_sqlite_SOURCES = \
199 test_namestore_api_zone_to_name.c
200test_namestore_api_zone_to_name_sqlite_LDADD = \
201 $(top_builddir)/src/service/identity/libgnunetidentity.la \
202 $(top_builddir)/src/service/testing/libgnunettesting.la \
203 $(top_builddir)/src/lib/util/libgnunetutil.la \
204 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
205
206test_namestore_api_zone_to_name_postgres_SOURCES = \
207 test_namestore_api_zone_to_name.c
208test_namestore_api_zone_to_name_postgres_LDADD = \
209 $(top_builddir)/src/service/identity/libgnunetidentity.la \
210 $(top_builddir)/src/service/testing/libgnunettesting.la \
211 $(top_builddir)/src/lib/util/libgnunetutil.la \
212 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
213
214test_namestore_api_monitoring_sqlite_SOURCES = \
215 test_namestore_api_monitoring.c
216test_namestore_api_monitoring_sqlite_LDADD = \
217 $(top_builddir)/src/service/identity/libgnunetidentity.la \
218 $(top_builddir)/src/service/testing/libgnunettesting.la \
219 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
220 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
221 $(top_builddir)/src/lib/util/libgnunetutil.la
222
223test_namestore_api_monitoring_postgres_SOURCES = \
224 test_namestore_api_monitoring.c
225test_namestore_api_monitoring_postgres_LDADD = \
226 $(top_builddir)/src/service/testing/libgnunettesting.la \
227 $(top_builddir)/src/service/identity/libgnunetidentity.la \
228 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
229 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
230 $(top_builddir)/src/lib/util/libgnunetutil.la
231
232test_namestore_api_monitoring_existing_sqlite_SOURCES = \
233 test_namestore_api_monitoring_existing.c
234test_namestore_api_monitoring_existing_sqlite_LDADD = \
235 $(top_builddir)/src/service/testing/libgnunettesting.la \
236 $(top_builddir)/src/service/identity/libgnunetidentity.la \
237 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
238 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
239 $(top_builddir)/src/lib/util/libgnunetutil.la
240
241test_namestore_api_monitoring_existing_postgres_SOURCES = \
242 test_namestore_api_monitoring_existing.c
243test_namestore_api_monitoring_existing_postgres_LDADD = \
244 $(top_builddir)/src/service/testing/libgnunettesting.la \
245 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
246 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
247 $(top_builddir)/src/service/identity/libgnunetidentity.la \
248 $(top_builddir)/src/lib/util/libgnunetutil.la
249
250test_namestore_api_tx_rollback_sqlite_SOURCES = \
251 test_namestore_api_tx_rollback.c
252test_namestore_api_tx_rollback_sqlite_LDADD = \
253 $(top_builddir)/src/service/testing/libgnunettesting.la \
254 $(top_builddir)/src/service/identity/libgnunetidentity.la \
255 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
256 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
257 $(top_builddir)/src/lib/util/libgnunetutil.la
258
259test_namestore_api_tx_rollback_postgres_SOURCES = \
260 test_namestore_api_tx_rollback.c
261test_namestore_api_tx_rollback_postgres_LDADD = \
262 $(top_builddir)/src/service/testing/libgnunettesting.la \
263 $(top_builddir)/src/service/identity/libgnunetidentity.la \
264 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
265 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
266 $(top_builddir)/src/lib/util/libgnunetutil.la
267
268if HAVE_EXPERIMENTAL
269test_namestore_api_edit_records_postgres_SOURCES = \
270 test_namestore_api_edit_records.c
271test_namestore_api_edit_records_postgres_LDADD = \
272 $(top_builddir)/src/service/testing/libgnunettesting.la \
273 $(top_builddir)/src/service/identity/libgnunetidentity.la \
274 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
275 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
276 $(top_builddir)/src/lib/util/libgnunetutil.la
277endif 52endif
278 53
279test_namestore_api_zone_iteration_sqlite_SOURCES = \
280 test_namestore_api_zone_iteration.c
281test_namestore_api_zone_iteration_sqlite_LDADD = \
282 $(top_builddir)/src/service/testing/libgnunettesting.la \
283 $(top_builddir)/src/service/identity/libgnunetidentity.la \
284 $(top_builddir)/src/lib/util/libgnunetutil.la \
285 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
286 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
287
288test_namestore_api_zone_iteration_postgres_SOURCES = \
289 test_namestore_api_zone_iteration.c
290test_namestore_api_zone_iteration_postgres_LDADD = \
291 $(top_builddir)/src/service/testing/libgnunettesting.la \
292 $(top_builddir)/src/service/identity/libgnunetidentity.la \
293 $(top_builddir)/src/lib/util/libgnunetutil.la \
294 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
295 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
296
297perf_namestore_api_zone_iteration_postgres_SOURCES = \
298 perf_namestore_api_zone_iteration.c
299perf_namestore_api_zone_iteration_postgres_LDADD = \
300 $(top_builddir)/src/service/testing/libgnunettesting.la \
301 $(top_builddir)/src/lib/util/libgnunetutil.la \
302 $(top_builddir)/src/service/identity/libgnunetidentity.la \
303 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
304 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
305
306perf_namestore_api_import_sqlite_SOURCES = \
307 perf_namestore_api_import.c
308perf_namestore_api_import_sqlite_LDADD = \
309 $(top_builddir)/src/service/testing/libgnunettesting.la \
310 $(top_builddir)/src/lib/util/libgnunetutil.la \
311 $(top_builddir)/src/service/identity/libgnunetidentity.la \
312 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
313 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
314
315perf_namestore_api_import_postgres_SOURCES = \
316 perf_namestore_api_import.c
317perf_namestore_api_import_postgres_LDADD = \
318 $(top_builddir)/src/service/testing/libgnunettesting.la \
319 $(top_builddir)/src/lib/util/libgnunetutil.la \
320 $(top_builddir)/src/service/identity/libgnunetidentity.la \
321 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
322 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
323
324 54
325perf_namestore_api_zone_iteration_sqlite_SOURCES = \ 55if HAVE_POSTGRESQL
326 perf_namestore_api_zone_iteration.c 56POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
327perf_namestore_api_zone_iteration_sqlite_LDADD = \ 57POSTGRES_TESTS = test_plugin_namestore_postgres
328 $(top_builddir)/src/service/testing/libgnunettesting.la \ 58endif
329 $(top_builddir)/src/service/identity/libgnunetidentity.la \ 59if HAVE_SQLITE
330 $(top_builddir)/src/lib/util/libgnunetutil.la \ 60check_PROGRAMS = \
331 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \ 61 $(SQLITE_TESTS) \
332 $(top_builddir)/src/service/namestore/libgnunetnamestore.la 62 $(POSTGRES_TESTS)
333 63endif
334test_namestore_api_zone_iteration_nick_sqlite_SOURCES = \
335 test_namestore_api_zone_iteration_nick.c
336test_namestore_api_zone_iteration_nick_sqlite_LDADD = \
337 $(top_builddir)/src/service/testing/libgnunettesting.la \
338 $(top_builddir)/src/service/identity/libgnunetidentity.la \
339 $(top_builddir)/src/lib/util/libgnunetutil.la \
340 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
341 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
342
343test_namestore_api_zone_iteration_nick_postgres_SOURCES = \
344 test_namestore_api_zone_iteration_nick.c
345test_namestore_api_zone_iteration_nick_postgres_LDADD = \
346 $(top_builddir)/src/service/testing/libgnunettesting.la \
347 $(top_builddir)/src/service/identity/libgnunetidentity.la \
348 $(top_builddir)/src/lib/util/libgnunetutil.la \
349 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
350 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
351
352test_namestore_api_zone_iteration_specific_zone_sqlite_SOURCES = \
353 test_namestore_api_zone_iteration_specific_zone.c
354test_namestore_api_zone_iteration_specific_zone_sqlite_LDADD = \
355 $(top_builddir)/src/service/testing/libgnunettesting.la \
356 $(top_builddir)/src/service/identity/libgnunetidentity.la \
357 $(top_builddir)/src/lib/util/libgnunetutil.la \
358 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
359 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
360
361test_namestore_api_zone_iteration_specific_zone_postgres_SOURCES = \
362 test_namestore_api_zone_iteration_specific_zone.c
363test_namestore_api_zone_iteration_specific_zone_postgres_LDADD = \
364 $(top_builddir)/src/service/testing/libgnunettesting.la \
365 $(top_builddir)/src/service/identity/libgnunetidentity.la \
366 $(top_builddir)/src/lib/util/libgnunetutil.la \
367 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
368 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
369
370test_namestore_api_zone_iteration_stop_sqlite_SOURCES = \
371 test_namestore_api_zone_iteration_stop.c
372test_namestore_api_zone_iteration_stop_sqlite_LDADD = \
373 $(top_builddir)/src/service/testing/libgnunettesting.la \
374 $(top_builddir)/src/service/identity/libgnunetidentity.la \
375 $(top_builddir)/src/lib/util/libgnunetutil.la \
376 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
377 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
378
379test_namestore_api_zone_iteration_stop_postgres_SOURCES = \
380 test_namestore_api_zone_iteration_stop.c
381test_namestore_api_zone_iteration_stop_postgres_LDADD = \
382 $(top_builddir)/src/service/testing/libgnunettesting.la \
383 $(top_builddir)/src/service/identity/libgnunetidentity.la \
384 $(top_builddir)/src/lib/util/libgnunetutil.la \
385 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
386 $(top_builddir)/src/service/namestore/libgnunetnamestore.la
387 64
388test_plugin_namestore_sqlite_SOURCES = \ 65test_plugin_namestore_sqlite_SOURCES = \
389 test_plugin_namestore.c 66 test_plugin_namestore.c
390test_plugin_namestore_sqlite_LDADD = \ 67test_plugin_namestore_sqlite_LDADD = \
391 $(top_builddir)/src/service/testing/libgnunettesting.la \
392 $(top_builddir)/src/service/identity/libgnunetidentity.la \
393 $(top_builddir)/src/lib/util/libgnunetutil.la 68 $(top_builddir)/src/lib/util/libgnunetutil.la
394 69
395test_plugin_namestore_postgres_SOURCES = \ 70test_plugin_namestore_postgres_SOURCES = \
396 test_plugin_namestore.c 71 test_plugin_namestore.c
397test_plugin_namestore_postgres_LDADD = \ 72test_plugin_namestore_postgres_LDADD = \
398 $(top_builddir)/src/service/identity/libgnunetidentity.la \
399 $(top_builddir)/src/service/testing/libgnunettesting.la \
400 $(top_builddir)/src/lib/util/libgnunetutil.la 73 $(top_builddir)/src/lib/util/libgnunetutil.la
401 74
402EXTRA_DIST = \ 75EXTRA_DIST = \
403 test_common.c \
404 test_namestore_api.conf \
405 test_namestore_api_postgres.conf \
406 test_namestore_api_sqlite.conf \
407 perf_namestore_api_postgres.conf \
408 perf_namestore_api_sqlite.conf \
409 test_plugin_namestore_sqlite.conf \ 76 test_plugin_namestore_sqlite.conf \
410 test_plugin_namestore_postgres.conf \ 77 test_plugin_namestore_postgres.conf \
411 $(sql_DATA) 78 $(sql_DATA)
79