aboutsummaryrefslogtreecommitdiff
path: root/src/plugin/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugin/namestore/Makefile.am')
-rw-r--r--src/plugin/namestore/Makefile.am79
1 files changed, 79 insertions, 0 deletions
diff --git a/src/plugin/namestore/Makefile.am b/src/plugin/namestore/Makefile.am
new file mode 100644
index 000000000..3db174225
--- /dev/null
+++ b/src/plugin/namestore/Makefile.am
@@ -0,0 +1,79 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include $(POSTGRESQL_CPPFLAGS)
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10sqldir = $(prefix)/share/gnunet/sql/
11
12sql_DATA = \
13 namestore-0001.sql \
14 namestore-drop.sql
15
16if USE_COVERAGE
17 AM_CFLAGS = --coverage -O0
18 XLIBS = -lgcov
19endif
20
21
22
23
24plugin_LTLIBRARIES = \
25 $(SQLITE_PLUGIN) \
26 $(POSTGRES_PLUGIN)
27
28
29libgnunet_plugin_namestore_sqlite_la_SOURCES = \
30 plugin_namestore_sqlite.c
31libgnunet_plugin_namestore_sqlite_la_LIBADD = \
32 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
33 $(top_builddir)/src/lib/sq/libgnunetsq.la \
34 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
35 $(LTLIBINTL)
36libgnunet_plugin_namestore_sqlite_la_LDFLAGS = \
37 $(GN_PLUGIN_LDFLAGS)
38
39libgnunet_plugin_namestore_postgres_la_SOURCES = \
40 plugin_namestore_postgres.c
41libgnunet_plugin_namestore_postgres_la_LIBADD = \
42 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
43 $(top_builddir)/src/lib/pq/libgnunetpq.la \
44 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIBS) -lpq \
45 $(LTLIBINTL)
46libgnunet_plugin_namestore_postgres_la_LDFLAGS = \
47 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
48
49if HAVE_SQLITE
50SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
51SQLITE_TESTS = test_plugin_namestore_sqlite
52endif
53
54
55if HAVE_POSTGRESQL
56POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
57POSTGRES_TESTS = test_plugin_namestore_postgres
58endif
59if HAVE_SQLITE
60check_PROGRAMS = \
61 $(SQLITE_TESTS) \
62 $(POSTGRES_TESTS)
63endif
64
65test_plugin_namestore_sqlite_SOURCES = \
66 test_plugin_namestore.c
67test_plugin_namestore_sqlite_LDADD = \
68 $(top_builddir)/src/lib/util/libgnunetutil.la
69
70test_plugin_namestore_postgres_SOURCES = \
71 test_plugin_namestore.c
72test_plugin_namestore_postgres_LDADD = \
73 $(top_builddir)/src/lib/util/libgnunetutil.la
74
75EXTRA_DIST = \
76 test_plugin_namestore_sqlite.conf \
77 test_plugin_namestore_postgres.conf \
78 $(sql_DATA)
79