aboutsummaryrefslogtreecommitdiff
path: root/src/plugin/namestore/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugin/namestore/meson.build')
-rw-r--r--src/plugin/namestore/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/plugin/namestore/meson.build b/src/plugin/namestore/meson.build
index d51b4b730..4a077915d 100644
--- a/src/plugin/namestore/meson.build
+++ b/src/plugin/namestore/meson.build
@@ -10,6 +10,10 @@ shared_module('gnunet_plugin_namestore_sqlite',
10 install: true, 10 install: true,
11 install_dir: get_option('libdir')/'gnunet') 11 install_dir: get_option('libdir')/'gnunet')
12 12
13configure_file(copy: true,
14 input: 'test_plugin_namestore_sqlite.conf',
15 output: 'test_plugin_namestore_sqlite.conf')
16
13if pq_dep.found() 17if pq_dep.found()
14 shared_module('gnunet_plugin_namestore_postgres', 18 shared_module('gnunet_plugin_namestore_postgres',
15 ['plugin_namestore_postgres.c'], 19 ['plugin_namestore_postgres.c'],
@@ -20,5 +24,28 @@ if pq_dep.found()
20 include_directories: [incdir, configuration_inc], 24 include_directories: [incdir, configuration_inc],
21 install: true, 25 install: true,
22 install_dir: get_option('libdir')/'gnunet') 26 install_dir: get_option('libdir')/'gnunet')
27configure_file(copy: true,
28 input: 'test_plugin_namestore_postgres.conf',
29 output: 'test_plugin_namestore_postgres.conf')
30
31 testpluginnamestore_pq = executable ('test_plugin_namestore_postgres',
32 ['test_plugin_namestore.c'],
33 dependencies: [
34 libgnunetutil_dep
35 ],
36 include_directories: [incdir, configuration_inc],
37 install: false)
38 test('test_plugin_namestore_postgres', testpluginnamestore_pq, workdir: meson.current_build_dir(),
39 suite: 'namestore')
23endif 40endif
24 41
42testpluginnamestore_sq = executable ('test_plugin_namestore_sqlite',
43 ['test_plugin_namestore.c'],
44 dependencies: [
45 libgnunetutil_dep
46 ],
47 include_directories: [incdir, configuration_inc],
48 install: false)
49test('test_plugin_namestore_sqlite', testpluginnamestore_sq, workdir: meson.current_build_dir(),
50 suite: 'namestore')
51