aboutsummaryrefslogtreecommitdiff
path: root/src/plugin/namestore/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugin/namestore/meson.build')
-rw-r--r--src/plugin/namestore/meson.build51
1 files changed, 51 insertions, 0 deletions
diff --git a/src/plugin/namestore/meson.build b/src/plugin/namestore/meson.build
new file mode 100644
index 000000000..4a077915d
--- /dev/null
+++ b/src/plugin/namestore/meson.build
@@ -0,0 +1,51 @@
1libgnunetpluginnamestore_sqlite_src = ['plugin_namestore_sqlite.c']
2
3shared_module('gnunet_plugin_namestore_sqlite',
4 libgnunetpluginnamestore_sqlite_src,
5 dependencies: [libgnunetutil_dep,
6 libgnunetgnsrecord_dep,
7 libgnunetsq_dep,
8 sqlite_dep],
9 include_directories: [incdir, configuration_inc],
10 install: true,
11 install_dir: get_option('libdir')/'gnunet')
12
13configure_file(copy: true,
14 input: 'test_plugin_namestore_sqlite.conf',
15 output: 'test_plugin_namestore_sqlite.conf')
16
17if pq_dep.found()
18 shared_module('gnunet_plugin_namestore_postgres',
19 ['plugin_namestore_postgres.c'],
20 dependencies: [libgnunetutil_dep,
21 libgnunetgnsrecord_dep,
22 libgnunetpq_dep,
23 pq_dep],
24 include_directories: [incdir, configuration_inc],
25 install: true,
26 install_dir: get_option('libdir')/'gnunet')
27configure_file(copy: true,
28 input: 'test_plugin_namestore_postgres.conf',
29 output: 'test_plugin_namestore_postgres.conf')
30
31 testpluginnamestore_pq = executable ('test_plugin_namestore_postgres',
32 ['test_plugin_namestore.c'],
33 dependencies: [
34 libgnunetutil_dep
35 ],
36 include_directories: [incdir, configuration_inc],
37 install: false)
38 test('test_plugin_namestore_postgres', testpluginnamestore_pq, workdir: meson.current_build_dir(),
39 suite: 'namestore')
40endif
41
42testpluginnamestore_sq = executable ('test_plugin_namestore_sqlite',
43 ['test_plugin_namestore.c'],
44 dependencies: [
45 libgnunetutil_dep
46 ],
47 include_directories: [incdir, configuration_inc],
48 install: false)
49test('test_plugin_namestore_sqlite', testpluginnamestore_sq, workdir: meson.current_build_dir(),
50 suite: 'namestore')
51