aboutsummaryrefslogtreecommitdiff
path: root/src/plugin/regex/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugin/regex/Makefile.am')
-rw-r--r--src/plugin/regex/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/plugin/regex/Makefile.am b/src/plugin/regex/Makefile.am
new file mode 100644
index 000000000..a39cfc927
--- /dev/null
+++ b/src/plugin/regex/Makefile.am
@@ -0,0 +1,40 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage
6endif
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10libexecdir= $(pkglibdir)/libexec/
11
12plugindir = $(libdir)/gnunet
13
14lib_LTLIBRARIES = \
15 libgnunetregexblock.la
16
17libgnunetregexblock_la_SOURCES = \
18 regex_block_lib.c regex_block_lib.h
19libgnunetregexblock_la_LIBADD = \
20 $(top_builddir)/src/lib/util/libgnunetutil.la \
21 $(XLIB) \
22 $(LTLIBINTL)
23libgnunetregexblock_la_LDFLAGS = \
24 $(GN_LIB_LDFLAGS) \
25 -version-info 1:0:0
26
27
28plugin_LTLIBRARIES = \
29 libgnunet_plugin_block_regex.la
30
31libgnunet_plugin_block_regex_la_SOURCES = \
32 plugin_block_regex.c
33libgnunet_plugin_block_regex_la_LIBADD = \
34 libgnunetregexblock.la \
35 $(top_builddir)/src/lib/block/libgnunetblock.la \
36 $(top_builddir)/src/lib/block/libgnunetblockgroup.la \
37 $(top_builddir)/src/lib/util/libgnunetutil.la
38libgnunet_plugin_block_regex_la_LDFLAGS = \
39 $(GN_LIBINTL) \
40 $(GN_PLUGIN_LDFLAGS)