aboutsummaryrefslogtreecommitdiff
path: root/src/plugin/seti/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugin/seti/Makefile.am')
-rw-r--r--src/plugin/seti/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/plugin/seti/Makefile.am b/src/plugin/seti/Makefile.am
new file mode 100644
index 000000000..e6f579a65
--- /dev/null
+++ b/src/plugin/seti/Makefile.am
@@ -0,0 +1,25 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8plugindir = $(libdir)/gnunet
9
10if USE_COVERAGE
11 AM_CFLAGS = -fprofile-arcs -ftest-coverage
12endif
13
14plugin_LTLIBRARIES = \
15 libgnunet_plugin_block_seti_test.la
16
17libgnunet_plugin_block_seti_test_la_SOURCES = \
18 plugin_block_seti_test.c
19libgnunet_plugin_block_seti_test_la_LIBADD = \
20 $(top_builddir)/src/lib/block/libgnunetblock.la \
21 $(top_builddir)/src/lib/block/libgnunetblockgroup.la \
22 $(top_builddir)/src/lib/util/libgnunetutil.la \
23 $(LTLIBINTL)
24libgnunet_plugin_block_seti_test_la_LDFLAGS = \
25 $(GN_PLUGIN_LDFLAGS)