aboutsummaryrefslogtreecommitdiff
path: root/src/pq/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/pq/meson.build')
-rw-r--r--src/pq/meson.build16
1 files changed, 10 insertions, 6 deletions
diff --git a/src/pq/meson.build b/src/pq/meson.build
index 273a0c0fb..7e9060b41 100644
--- a/src/pq/meson.build
+++ b/src/pq/meson.build
@@ -7,14 +7,18 @@ libgnunetpq_src = ['pq.c',
7 'pq_query_helper.c', 7 'pq_query_helper.c',
8 'pq_result_helper.c'] 8 'pq_result_helper.c']
9 9
10if get_option('monolith') == false 10if get_option('monolith')
11 libgnunetpq = library('gnunetpq',
12 libgnunetpq_src,
13 dependencies: [libgnunetutil_dep, pq_dep],
14 include_directories: [incdir, configuration_inc])
15 libgnunetpq_dep = declare_dependency(link_with : libgnunetpq)
16else 11else
17 foreach p : libgnunetpq_src 12 foreach p : libgnunetpq_src
18 gnunet_src += 'pq/' + p 13 gnunet_src += 'pq/' + p
19 endforeach 14 endforeach
15 subdir_done()
20endif 16endif
17
18libgnunetpq = library('gnunetpq',
19 libgnunetpq_src,
20 dependencies: [libgnunetutil_dep, pq_dep],
21 include_directories: [incdir, configuration_inc],
22 install: true,
23 install_dir: get_option('libdir'))
24libgnunetpq_dep = declare_dependency(link_with : libgnunetpq)