aboutsummaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am196
1 files changed, 0 insertions, 196 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
deleted file mode 100644
index a6c9c0903..000000000
--- a/src/regex/Makefile.am
+++ /dev/null
@@ -1,196 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage
6endif
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10libexecdir= $(pkglibdir)/libexec/
11
12plugindir = $(libdir)/gnunet
13
14pkgcfg_DATA = \
15 regex.conf
16
17libexec_PROGRAMS = \
18 gnunet-service-regex \
19 gnunet-daemon-regexprofiler
20
21REGEX_INTERNAL = \
22 regex_internal_lib.h \
23 regex_internal.h regex_internal.c \
24 regex_internal_dht.c
25REGEX_INTERNAL_TEST = \
26 $(REGEX_INTERNAL) \
27 regex_test_lib.c regex_test_lib.h \
28 regex_test_graph.c \
29 regex_test_random.c
30
31gnunet_service_regex_SOURCES = \
32 $(REGEX_INTERNAL) gnunet-service-regex.c
33gnunet_service_regex_LDADD = -lm \
34 libgnunetregexblock.la \
35 $(top_builddir)/src/dht/libgnunetdht.la \
36 $(top_builddir)/src/statistics/libgnunetstatistics.la \
37 $(top_builddir)/src/util/libgnunetutil.la \
38 $(GN_LIBINTL)
39
40lib_LTLIBRARIES = \
41 libgnunetregexblock.la \
42 libgnunetregex.la
43
44libgnunetregexblock_la_SOURCES = \
45 regex_block_lib.c regex_block_lib.h
46libgnunetregexblock_la_LIBADD = \
47 $(top_builddir)/src/util/libgnunetutil.la \
48 $(XLIB) \
49 $(LTLIBINTL)
50libgnunetregexblock_la_LDFLAGS = \
51 $(GN_LIB_LDFLAGS) \
52 -version-info 1:0:0
53
54
55libgnunetregex_la_SOURCES = \
56 regex_api_announce.c \
57 regex_api_search.c \
58 regex_ipc.h
59libgnunetregex_la_LIBADD = \
60 $(top_builddir)/src/util/libgnunetutil.la
61libgnunetregex_la_LDFLAGS = \
62 $(GN_LIBINTL) \
63 $(GN_LIB_LDFLAGS) \
64 -version-info 3:1:0
65
66
67plugin_LTLIBRARIES = \
68 libgnunet_plugin_block_regex.la
69
70libgnunet_plugin_block_regex_la_SOURCES = \
71 plugin_block_regex.c
72libgnunet_plugin_block_regex_la_LIBADD = \
73 libgnunetregexblock.la \
74 $(top_builddir)/src/block/libgnunetblock.la \
75 $(top_builddir)/src/block/libgnunetblockgroup.la \
76 $(top_builddir)/src/util/libgnunetutil.la
77libgnunet_plugin_block_regex_la_LDFLAGS = \
78 $(GN_LIBINTL) \
79 $(GN_PLUGIN_LDFLAGS)
80
81if HAVE_MYSQL
82noinst_mysql_progs = \
83 gnunet-regex-simulation-profiler
84
85gnunet_regex_simulation_profiler_SOURCES = \
86 $(REGEX_INTERNAL) gnunet-regex-simulation-profiler.c
87gnunet_regex_simulation_profiler_LDADD = \
88 libgnunetregexblock.la \
89 $(top_builddir)/src/util/libgnunetutil.la \
90 $(top_builddir)/src/dht/libgnunetdht.la \
91 $(top_builddir)/src/my/libgnunetmy.la \
92 $(top_builddir)/src/mysql/libgnunetmysql.la \
93 $(top_builddir)/src/block/libgnunetblock.la \
94 $(top_builddir)/src/statistics/libgnunetstatistics.la
95endif
96
97noinst_PROGRAMS = $(noinst_mysql_progs) \
98 perf-regex \
99 gnunet-regex-profiler
100
101perf_regex_SOURCES = \
102 $(REGEX_INTERNAL_TEST) perf-regex.c
103perf_regex_LDADD = -lm \
104 $(top_builddir)/src/dht/libgnunetdht.la \
105 libgnunetregexblock.la \
106 $(top_builddir)/src/util/libgnunetutil.la \
107 $(top_builddir)/src/statistics/libgnunetstatistics.la
108perf_regex_LDFLAGS = \
109 $(GN_LIBINTL)
110
111gnunet_regex_profiler_SOURCES = \
112 $(REGEX_INTERNAL_TEST) gnunet-regex-profiler.c
113gnunet_regex_profiler_LDADD = -lm \
114 $(top_builddir)/src/arm/libgnunetarm.la \
115 $(top_builddir)/src/testing/libgnunettesting.la \
116 $(top_builddir)/src/testbed/libgnunettestbed.la \
117 $(top_builddir)/src/dht/libgnunetdht.la \
118 libgnunetregexblock.la \
119 $(top_builddir)/src/statistics/libgnunetstatistics.la \
120 $(top_builddir)/src/util/libgnunetutil.la
121gnunet_regex_profiler_LDFLAGS = \
122 $(GN_LIBINTL)
123
124gnunet_daemon_regexprofiler_SOURCES = \
125 $(REGEX_INTERNAL_TEST) gnunet-daemon-regexprofiler.c
126gnunet_daemon_regexprofiler_LDADD = -lm \
127 $(top_builddir)/src/dht/libgnunetdht.la \
128 libgnunetregexblock.la \
129 $(top_builddir)/src/statistics/libgnunetstatistics.la \
130 $(top_builddir)/src/util/libgnunetutil.la
131gnunet_daemon_regexprofiler_LDFLAGS = \
132 $(GN_LIBINTL)
133
134check_PROGRAMS = \
135 test_regex_integration \
136 test_regex_eval_api \
137 test_regex_iterate_api \
138 test_regex_proofs \
139 test_regex_graph_api \
140 test_regex_api
141
142if ENABLE_TEST_RUN
143 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
144 TESTS = $(check_PROGRAMS)
145endif
146
147test_regex_eval_api_SOURCES = \
148 $(REGEX_INTERNAL_TEST) test_regex_eval_api.c
149test_regex_eval_api_LDADD = -lm \
150 $(top_builddir)/src/dht/libgnunetdht.la \
151 libgnunetregexblock.la \
152 $(top_builddir)/src/statistics/libgnunetstatistics.la \
153 $(top_builddir)/src/util/libgnunetutil.la
154
155test_regex_integration_SOURCES = \
156 test_regex_integration.c
157test_regex_integration_LDADD = -lm \
158 libgnunetregex.la \
159 $(top_builddir)/src/testing/libgnunettesting.la \
160 $(top_builddir)/src/util/libgnunetutil.la
161
162test_regex_api_SOURCES = \
163 test_regex_api.c
164test_regex_api_LDADD = -lm \
165 libgnunetregex.la \
166 $(top_builddir)/src/testing/libgnunettesting.la \
167 $(top_builddir)/src/util/libgnunetutil.la
168
169test_regex_iterate_api_SOURCES = \
170 $(REGEX_INTERNAL) test_regex_iterate_api.c
171test_regex_iterate_api_LDADD = -lm \
172 libgnunetregexblock.la \
173 $(top_builddir)/src/dht/libgnunetdht.la \
174 $(top_builddir)/src/statistics/libgnunetstatistics.la \
175 $(top_builddir)/src/util/libgnunetutil.la
176
177test_regex_proofs_SOURCES = \
178 $(REGEX_INTERNAL_TEST) test_regex_proofs.c
179test_regex_proofs_LDADD = -lm \
180 $(top_builddir)/src/dht/libgnunetdht.la \
181 libgnunetregexblock.la \
182 $(top_builddir)/src/statistics/libgnunetstatistics.la \
183 $(top_builddir)/src/util/libgnunetutil.la
184
185test_regex_graph_api_SOURCES = \
186 $(REGEX_INTERNAL_TEST) test_regex_graph_api.c
187test_regex_graph_api_LDADD = -lm \
188 $(top_builddir)/src/dht/libgnunetdht.la \
189 libgnunetregexblock.la \
190 $(top_builddir)/src/statistics/libgnunetstatistics.la \
191 $(top_builddir)/src/util/libgnunetutil.la
192
193
194EXTRA_DIST = \
195 regex_simulation_profiler_test.conf \
196 test_regex_api_data.conf