aboutsummaryrefslogtreecommitdiff
path: root/src/regex/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/regex/meson.build')
-rw-r--r--src/regex/meson.build53
1 files changed, 33 insertions, 20 deletions
diff --git a/src/regex/meson.build b/src/regex/meson.build
index f9e8c0ee1..cb5140128 100644
--- a/src/regex/meson.build
+++ b/src/regex/meson.build
@@ -13,27 +13,40 @@ configure_file(input : 'regex.conf.in',
13 install_dir: pkgcfgdir) 13 install_dir: pkgcfgdir)
14 14
15 15
16if get_option('monolith') == false 16if get_option('monolith')
17 libgnunetregex = library('gnunetregex',
18 libgnunetregex_src,
19 dependencies: libgnunetutil_dep,
20 include_directories: [incdir, configuration_inc])
21 libgnunetregex_dep = declare_dependency(link_with : libgnunetregex)
22 libgnunetregexblock = library('gnunetregexblock',
23 libgnunetregexblock_src,
24 dependencies: libgnunetutil_dep,
25 include_directories: [incdir, configuration_inc])
26 libgnunetregexblock_dep = declare_dependency(link_with : libgnunetregexblock)
27 executable ('gnunet-service-regex',
28 gnunetserviceregex_src,
29 dependencies: [libgnunetregex_dep, libgnunetutil_dep,
30 libgnunetdht_dep,
31 libgnunetstatistics_dep,
32 libgnunetregex_dep,
33 libgnunetregexblock_dep],
34 include_directories: [incdir, configuration_inc])
35else
36 foreach p : libgnunetregex_src + libgnunetregexblock_src + gnunetserviceregex_src 17 foreach p : libgnunetregex_src + libgnunetregexblock_src + gnunetserviceregex_src
37 gnunet_src += 'regex/' + p 18 gnunet_src += 'regex/' + p
38 endforeach 19 endforeach
20 subdir_done()
39endif 21endif
22
23libgnunetregex = library('gnunetregex',
24 libgnunetregex_src,
25 soversion: '3.1.0',
26 dependencies: libgnunetutil_dep,
27 include_directories: [incdir, configuration_inc],
28 install: true,
29 install_dir: get_option('libdir'))
30pkg.generate(libgnunetregex, url: 'https://www.gnunet.org',
31 description : 'Provides API for accessing the regex service')
32libgnunetregex_dep = declare_dependency(link_with : libgnunetregex)
33libgnunetregexblock = library('gnunetregexblock',
34 libgnunetregexblock_src,
35 soversion: '1.0.0',
36 dependencies: libgnunetutil_dep,
37 include_directories: [incdir, configuration_inc],
38 install: true,
39 install_dir: get_option('libdir'))
40libgnunetregexblock_dep = declare_dependency(link_with : libgnunetregexblock)
41
42executable ('gnunet-service-regex',
43 gnunetserviceregex_src,
44 dependencies: [libgnunetregex_dep, libgnunetutil_dep,
45 libgnunetdht_dep,
46 libgnunetstatistics_dep,
47 libgnunetregex_dep,
48 libgnunetregexblock_dep],
49 include_directories: [incdir, configuration_inc],
50 install: true,
51 install_dir: get_option('libdir')/'gnunet'/'libexec')
52