aboutsummaryrefslogtreecommitdiff
path: root/src/regex/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/regex/meson.build')
-rw-r--r--src/regex/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/regex/meson.build b/src/regex/meson.build
index f1bbfa1b8..c8c3fd506 100644
--- a/src/regex/meson.build
+++ b/src/regex/meson.build
@@ -41,6 +41,17 @@ libgnunetregexblock = library('gnunetregexblock',
41 install_dir: get_option('libdir')) 41 install_dir: get_option('libdir'))
42libgnunetregexblock_dep = declare_dependency(link_with : libgnunetregexblock) 42libgnunetregexblock_dep = declare_dependency(link_with : libgnunetregexblock)
43 43
44shared_module('gnunet_plugin_block_regex',
45 ['plugin_block_regex.c'],
46 dependencies: [libgnunetutil_dep,
47 libgnunetregexblock_dep,
48 libgnunetblock_dep,
49 libgnunetblockgroup_dep],
50 include_directories: [incdir, configuration_inc],
51 install:true,
52 install_dir: get_option('libdir')/'gnunet')
53
54
44executable ('gnunet-service-regex', 55executable ('gnunet-service-regex',
45 gnunetserviceregex_src, 56 gnunetserviceregex_src,
46 dependencies: [libgnunetregex_dep, libgnunetutil_dep, 57 dependencies: [libgnunetregex_dep, libgnunetutil_dep,