aboutsummaryrefslogtreecommitdiff
path: root/src/regex/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/regex/meson.build')
-rw-r--r--src/regex/meson.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/regex/meson.build b/src/regex/meson.build
new file mode 100644
index 000000000..31bb9c3e4
--- /dev/null
+++ b/src/regex/meson.build
@@ -0,0 +1,33 @@
1libgnunetregex_src = ['regex_api_announce.c',
2 'regex_api_search.c']
3libgnunetregexblock_src = ['regex_block_lib.c']
4
5gnunetserviceregex_src = ['gnunet-service-regex.c',
6 'regex_internal_dht.c',
7 'regex_internal.c']
8
9
10if gnunet_monolith == false
11 libgnunetregex = library('gnunetregex',
12 libgnunetregex_src,
13 dependencies: libgnunetutil_dep,
14 include_directories: [incdir, configuration_inc])
15 libgnunetregex_dep = declare_dependency(link_with : libgnunetregex)
16 libgnunetregexblock = library('gnunetregexblock',
17 libgnunetregexblock_src,
18 dependencies: libgnunetutil_dep,
19 include_directories: [incdir, configuration_inc])
20 libgnunetregexblock_dep = declare_dependency(link_with : libgnunetregexblock)
21 executable ('gnunet-service-regex',
22 gnunetserviceregex_src,
23 dependencies: [libgnunetregex_dep, libgnunetutil_dep,
24 libgnunetdht_dep,
25 libgnunetstatistics_dep,
26 libgnunetregex_dep,
27 libgnunetregexblock_dep],
28 include_directories: [incdir, configuration_inc])
29else
30 foreach p : libgnunetregex_src + gnunetserviceregex_src
31 gnunet_src += 'regex/' + p
32 endforeach
33endif