aboutsummaryrefslogtreecommitdiff
path: root/src/rest/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/rest/meson.build')
-rw-r--r--src/rest/meson.build32
1 files changed, 21 insertions, 11 deletions
diff --git a/src/rest/meson.build b/src/rest/meson.build
index 9b4314040..85a69c407 100644
--- a/src/rest/meson.build
+++ b/src/rest/meson.build
@@ -9,18 +9,28 @@ configure_file(input : 'rest.conf',
9 install_dir: pkgcfgdir) 9 install_dir: pkgcfgdir)
10 10
11 11
12if get_option('monolith') == false 12if get_option('monolith')
13 libgnunetrest = library('gnunetrest',
14 libgnunetrest_src,
15 dependencies: [libgnunetutil_dep, mhd_dep],
16 include_directories: [incdir, configuration_inc])
17 libgnunetrest_dep = declare_dependency(link_with : libgnunetrest)
18 executable ('gnunet-rest-server',
19 gnunetservicerest_src,
20 dependencies: [libgnunetrest_dep, libgnunetutil_dep, mhd_dep],
21 include_directories: [incdir, configuration_inc])
22else
23 foreach p : libgnunetrest_src + gnunetservicerest_src 13 foreach p : libgnunetrest_src + gnunetservicerest_src
24 gnunet_src += 'rest/' + p 14 gnunet_src += 'rest/' + p
25 endforeach 15 endforeach
16 subdir_done()
26endif 17endif
18
19
20libgnunetrest = library('gnunetrest',
21 libgnunetrest_src,
22 dependencies: [libgnunetutil_dep, mhd_dep],
23 include_directories: [incdir, configuration_inc],
24 install: true,
25 install_dir: get_option('libdir'))
26pkg.generate(libgnunetrest, url: 'https://www.gnunet.org',
27 description : 'Provides API for accessing the REST service')
28libgnunetrest_dep = declare_dependency(link_with : libgnunetrest)
29
30executable ('gnunet-rest-server',
31 gnunetservicerest_src,
32 dependencies: [libgnunetrest_dep, libgnunetutil_dep, mhd_dep],
33 include_directories: [incdir, configuration_inc],
34 install: true,
35 install_dir: get_option('libdir') / 'gnunet' / 'libexec')
36