aboutsummaryrefslogtreecommitdiff
path: root/src/rest/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/rest/meson.build')
-rw-r--r--src/rest/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/rest/meson.build b/src/rest/meson.build
new file mode 100644
index 000000000..f994e0a3e
--- /dev/null
+++ b/src/rest/meson.build
@@ -0,0 +1,20 @@
1libgnunetrest_src = ['rest.c']
2
3gnunetservicerest_src = ['gnunet-rest-server.c']
4
5
6if gnunet_monolith == false
7 libgnunetrest = library('gnunetrest',
8 libgnunetrest_src,
9 dependencies: [libgnunetutil_dep, mhd_dep],
10 include_directories: [incdir, configuration_inc])
11 libgnunetrest_dep = declare_dependency(link_with : libgnunetrest)
12 executable ('gnunet-rest-server',
13 gnunetservicerest_src,
14 dependencies: [libgnunetrest_dep, libgnunetutil_dep, mhd_dep],
15 include_directories: [incdir, configuration_inc])
16else
17 foreach p : libgnunetrest_src + gnunetservicerest_src
18 gnunet_src += 'rest/' + p
19 endforeach
20endif