aboutsummaryrefslogtreecommitdiff
path: root/src/revocation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/revocation/Makefile.am')
-rw-r--r--src/revocation/Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/src/revocation/Makefile.am b/src/revocation/Makefile.am
index 541c7120d..82755b485 100644
--- a/src/revocation/Makefile.am
+++ b/src/revocation/Makefile.am
@@ -1,6 +1,8 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include 2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3 3
4plugindir = $(libdir)/gnunet
5
4if MINGW 6if MINGW
5 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols 7 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
6endif 8endif
@@ -21,6 +23,20 @@ bin_PROGRAMS = \
21 gnunet-revocation 23 gnunet-revocation
22 24
23 25
26plugin_LTLIBRARIES = \
27 libgnunet_plugin_block_revocation.la
28
29libgnunet_plugin_block_revocation_la_SOURCES = \
30 plugin_block_revocation.c
31libgnunet_plugin_block_revocation_la_LIBADD = \
32 libgnunetrevocation.la \
33 $(top_builddir)/src/block/libgnunetblockgroup.la \
34 $(top_builddir)/src/util/libgnunetutil.la \
35 $(LTLIBINTL)
36libgnunet_plugin_block_revocation_la_LDFLAGS = \
37 $(GN_PLUGIN_LDFLAGS)
38
39
24gnunet_revocation_SOURCES = \ 40gnunet_revocation_SOURCES = \
25 gnunet-revocation.c 41 gnunet-revocation.c
26gnunet_revocation_LDADD = \ 42gnunet_revocation_LDADD = \
@@ -86,4 +102,3 @@ test_local_revocation.py: test_local_revocation.py.in Makefile
86 102
87EXTRA_DIST = test_revocation.conf \ 103EXTRA_DIST = test_revocation.conf \
88 test_local_revocation.py.in 104 test_local_revocation.py.in
89