aboutsummaryrefslogtreecommitdiff
path: root/src/revocation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/revocation/Makefile.am')
-rw-r--r--src/revocation/Makefile.am120
1 files changed, 0 insertions, 120 deletions
diff --git a/src/revocation/Makefile.am b/src/revocation/Makefile.am
deleted file mode 100644
index 71f30aab2..000000000
--- a/src/revocation/Makefile.am
+++ /dev/null
@@ -1,120 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6if USE_COVERAGE
7 AM_CFLAGS = --coverage -O0
8 XLIB = -lgcov
9endif
10
11pkgcfgdir= $(pkgdatadir)/config.d/
12
13libexecdir= $(pkglibdir)/libexec/
14
15pkgcfg_DATA = \
16 revocation.conf
17
18bin_PROGRAMS = \
19 gnunet-revocation
20
21plugin_LTLIBRARIES = \
22 libgnunet_plugin_block_revocation.la
23
24libgnunet_plugin_block_revocation_la_SOURCES = \
25 plugin_block_revocation.c
26libgnunet_plugin_block_revocation_la_LIBADD = \
27 libgnunetrevocation.la \
28 $(top_builddir)/src/block/libgnunetblockgroup.la \
29 $(top_builddir)/src/block/libgnunetblock.la \
30 $(top_builddir)/src/util/libgnunetutil.la \
31 $(top_builddir)/src/identity/libgnunetidentity.la \
32 $(LTLIBINTL)
33libgnunet_plugin_block_revocation_la_LDFLAGS = \
34 $(GN_PLUGIN_LDFLAGS)
35
36
37gnunet_revocation_SOURCES = \
38 gnunet-revocation.c
39gnunet_revocation_LDADD = \
40 libgnunetrevocation.la \
41 $(top_builddir)/src/identity/libgnunetidentity.la \
42 $(top_builddir)/src/util/libgnunetutil.la \
43 $(GN_LIBINTL)
44
45gnunet_revocation_tvg_SOURCES = \
46 gnunet-revocation-tvg.c
47gnunet_revocation_tvg_LDADD = \
48 libgnunetrevocation.la \
49 $(top_builddir)/src/identity/libgnunetidentity.la \
50 $(top_builddir)/src/util/libgnunetutil.la \
51 $(GN_LIBINTL)
52
53test_revocation_lsd0001testvectors_SOURCES = \
54 test_revocation_testvectors.c
55test_revocation_lsd0001testvectors_LDADD = \
56 $(top_builddir)/src/testing/libgnunettesting.la \
57 $(top_builddir)/src/identity/libgnunetidentity.la \
58 libgnunetrevocation.la \
59 $(top_builddir)/src/util/libgnunetutil.la
60
61lib_LTLIBRARIES = libgnunetrevocation.la
62
63libgnunetrevocation_la_SOURCES = \
64 revocation_api.c revocation.h
65libgnunetrevocation_la_LIBADD = \
66 $(top_builddir)/src/util/libgnunetutil.la \
67 $(top_builddir)/src/identity/libgnunetidentity.la \
68 $(LIBGCRYPT_LIBS) \
69 $(GN_LIBINTL) $(XLIB) -lgcrypt
70libgnunetrevocation_la_LDFLAGS = \
71 $(GN_LIB_LDFLAGS) \
72 -version-info 0:0:0
73
74libexec_PROGRAMS = \
75 gnunet-service-revocation
76
77noinst_PROGRAMS = \
78 gnunet-revocation-tvg
79
80gnunet_service_revocation_SOURCES = \
81 gnunet-service-revocation.c
82gnunet_service_revocation_LDADD = \
83 libgnunetrevocation.la \
84 $(top_builddir)/src/core/libgnunetcore.la \
85 $(top_builddir)/src/setu/libgnunetsetu.la \
86 $(top_builddir)/src/statistics/libgnunetstatistics.la \
87 $(top_builddir)/src/identity/libgnunetidentity.la \
88 $(top_builddir)/src/util/libgnunetutil.la \
89 -lm \
90 $(GN_LIBINTL)
91
92test_revocation_SOURCES = \
93 test_revocation.c
94test_revocation_LDADD = \
95 $(top_builddir)/src/identity/libgnunetidentity.la \
96 libgnunetrevocation.la \
97 $(top_builddir)/src//core/libgnunetcore.la \
98 $(top_builddir)/src/util/libgnunetutil.la \
99 $(top_builddir)/src/testbed/libgnunettestbed.la
100
101check_PROGRAMS = \
102 test_revocation \
103 test_revocation_lsd0001testvectors
104
105check_SCRIPTS = \
106 test_local_revocation.py
107
108if ENABLE_TEST_RUN
109 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
110 TESTS = \
111 $(check_SCRIPTS) \
112 $(check_PROGRAMS)
113endif
114
115test_local_revocation.py: test_local_revocation.py.in Makefile
116 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/test_local_revocation.py.in > test_local_revocation.py
117 chmod +x test_local_revocation.py
118
119EXTRA_DIST = test_revocation.conf \
120 test_local_revocation.py.in