aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am172
1 files changed, 0 insertions, 172 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
deleted file mode 100644
index b5e8c0617..000000000
--- a/src/rps/Makefile.am
+++ /dev/null
@@ -1,172 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9pkgcfgdir= $(pkgdatadir)/config.d/
10
11libexecdir= $(pkglibdir)/libexec/
12
13pkgcfg_DATA = \
14 rps.conf
15
16bin_PROGRAMS = gnunet-rps
17
18gnunet_rps_SOURCES = \
19 gnunet-rps.c
20
21gnunet_rps_LDADD = \
22 libgnunetrps.la \
23 $(top_builddir)/src/util/libgnunetutil.la \
24 $(XLIB) $(GN_LIBINTL)
25
26lib_LTLIBRARIES = libgnunetrps.la
27
28libgnunetrps_la_SOURCES = \
29 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
30 rps-test_util.h rps-test_util.c \
31 rps-sampler_common.h rps-sampler_common.c \
32 rps-sampler_client.h rps-sampler_client.c \
33 rps_api.c rps.h
34libgnunetrps_la_LIBADD = \
35 $(top_builddir)/src/nse/libgnunetnse.la \
36 $(top_builddir)/src/util/libgnunetutil.la \
37 $(GN_LIBINTL) $(XLIB)
38libgnunetrps_la_LDFLAGS = \
39 $(GN_LIB_LDFLAGS) \
40 -version-info 0:0:0
41# Fix 'created both with libtool and without' error:
42libgnunetrps_la_CFLAGS = $(AM_CFLAGS)
43
44
45libexec_PROGRAMS = \
46 gnunet-service-rps
47
48noinst_PROGRAMS = \
49 gnunet-rps-profiler
50
51
52gnunet_service_rps_SOURCES = \
53 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
54 rps-sampler_common.h rps-sampler_common.c \
55 gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c \
56 gnunet-service-rps_custommap.h gnunet-service-rps_custommap.c \
57 gnunet-service-rps_view.h gnunet-service-rps_view.c \
58 gnunet-service-rps.c
59
60
61gnunet_service_rps_LDADD = \
62 libgnunetrps.la \
63 $(top_builddir)/src/util/libgnunetutil.la \
64 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
65 $(top_builddir)/src/cadet/libgnunetcadet.la \
66 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
67 $(top_builddir)/src/nse/libgnunetnse.la \
68 $(top_builddir)/src/statistics/libgnunetstatistics.la \
69 $(top_builddir)/src/core/libgnunetcore.la \
70 $(LIBGCRYPT_LIBS) \
71 -lm -lgcrypt \
72 $(GN_LIBINTL)
73
74
75check_PROGRAMS = \
76 test_service_rps_view \
77 test_service_rps_custommap \
78 test_service_rps_sampler_elem \
79 test_rps_single_req \
80 test_rps_req_cancel \
81 test_rps_sub \
82 test_rps_seed_request \
83 test_rps_seed_big \
84 test_rps_churn
85if ENABLE_MALICIOUS
86check_PROGRAMS += \
87 test_rps_malicious_1 \
88 test_rps_malicious_2 \
89 test_rps_malicious_3
90endif
91
92rps_test_src = \
93 test_rps.c \
94 rps-test_util.h rps-test_util.c \
95 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
96 rps-sampler_common.h rps-sampler_common.c \
97 gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c
98
99ld_rps_test_lib = \
100 libgnunetrps.la \
101 $(top_builddir)/src/util/libgnunetutil.la \
102 $(top_builddir)/src/statistics/libgnunetstatistics.la \
103 $(top_builddir)/src/testbed/libgnunettestbed.la \
104 -lm
105
106if ENABLE_TEST_RUN
107AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
108TESTS = $(check_PROGRAMS)
109endif
110
111test_service_rps_view_SOURCES = \
112 gnunet-service-rps_view.h gnunet-service-rps_view.c \
113 test_service_rps_view.c
114test_service_rps_view_LDADD = $(top_builddir)/src/util/libgnunetutil.la
115
116test_service_rps_custommap_SOURCES = \
117 gnunet-service-rps_custommap.h gnunet-service-rps_custommap.c \
118 test_service_rps_custommap.c
119test_service_rps_custommap_LDADD = \
120 $(top_builddir)/src/util/libgnunetutil.la
121
122test_service_rps_sampler_elem_SOURCES = \
123 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
124 rps-test_util.h rps-test_util.c \
125 test_service_rps_sampler_elem.c
126test_service_rps_sampler_elem_LDADD = $(top_builddir)/src/util/libgnunetutil.la
127
128test_rps_single_req_SOURCES = $(rps_test_src)
129test_rps_single_req_LDADD = $(ld_rps_test_lib)
130
131test_rps_seed_request_SOURCES = $(rps_test_src)
132test_rps_seed_request_LDADD = $(ld_rps_test_lib)
133
134test_rps_req_cancel_SOURCES = $(rps_test_src)
135test_rps_req_cancel_LDADD = $(ld_rps_test_lib)
136
137test_rps_sub_SOURCES = $(rps_test_src)
138test_rps_sub_LDADD = $(ld_rps_test_lib)
139
140test_rps_seed_big_SOURCES = $(rps_test_src)
141test_rps_seed_big_LDADD = $(ld_rps_test_lib)
142
143test_rps_churn_SOURCES = $(rps_test_src)
144test_rps_churn_LDADD = $(ld_rps_test_lib)
145
146test_rps_malicious_1_SOURCES = $(rps_test_src)
147test_rps_malicious_1_LDADD = $(ld_rps_test_lib)
148
149test_rps_malicious_2_SOURCES = $(rps_test_src)
150test_rps_malicious_2_LDADD = $(ld_rps_test_lib)
151
152test_rps_malicious_3_SOURCES = $(rps_test_src)
153test_rps_malicious_3_LDADD = $(ld_rps_test_lib)
154
155gnunet_rps_profiler_SOURCES = \
156 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
157 rps-sampler_common.h rps-sampler_common.c \
158 gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c \
159 rps-test_util.h rps-test_util.c \
160 gnunet-rps-profiler.c
161
162
163gnunet_rps_profiler_LDADD = \
164 $(top_builddir)/src/statistics/libgnunetstatistics.la \
165 libgnunetrps.la \
166 $(top_builddir)/src/util/libgnunetutil.la \
167 $(top_builddir)/src/testbed/libgnunettestbed.la \
168 -lm
169
170
171EXTRA_DIST = \
172 test_rps.conf