aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am32
1 files changed, 18 insertions, 14 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
index e973bb7ca..8d2ddf7d7 100644
--- a/src/rps/Makefile.am
+++ b/src/rps/Makefile.am
@@ -79,14 +79,15 @@ check_PROGRAMS = \
79 test_service_rps_view \ 79 test_service_rps_view \
80 test_service_rps_custommap \ 80 test_service_rps_custommap \
81 test_service_rps_sampler_elem \ 81 test_service_rps_sampler_elem \
82 test_rps_malicious_1 \
83 test_rps_malicious_2 \
84 test_rps_malicious_3 \
85 test_rps_seed_request \
86 test_rps_single_req \ 82 test_rps_single_req \
87 test_rps_req_cancel \ 83 test_rps_req_cancel \
84 test_rps_sub \
85 test_rps_seed_request \
88 test_rps_seed_big \ 86 test_rps_seed_big \
89 test_rps_churn 87 test_rps_churn \
88 test_rps_malicious_1 \
89 test_rps_malicious_2 \
90 test_rps_malicious_3
90endif 91endif
91 92
92rps_test_src = \ 93rps_test_src = \
@@ -125,15 +126,6 @@ test_service_rps_sampler_elem_SOURCES = \
125 test_service_rps_sampler_elem.c 126 test_service_rps_sampler_elem.c
126test_service_rps_sampler_elem_LDADD = $(top_builddir)/src/util/libgnunetutil.la 127test_service_rps_sampler_elem_LDADD = $(top_builddir)/src/util/libgnunetutil.la
127 128
128test_rps_malicious_1_SOURCES = $(rps_test_src)
129test_rps_malicious_1_LDADD = $(ld_rps_test_lib)
130
131test_rps_malicious_2_SOURCES = $(rps_test_src)
132test_rps_malicious_2_LDADD = $(ld_rps_test_lib)
133
134test_rps_malicious_3_SOURCES = $(rps_test_src)
135test_rps_malicious_3_LDADD = $(ld_rps_test_lib)
136
137test_rps_single_req_SOURCES = $(rps_test_src) 129test_rps_single_req_SOURCES = $(rps_test_src)
138test_rps_single_req_LDADD = $(ld_rps_test_lib) 130test_rps_single_req_LDADD = $(ld_rps_test_lib)
139 131
@@ -143,12 +135,24 @@ test_rps_seed_request_LDADD = $(ld_rps_test_lib)
143test_rps_req_cancel_SOURCES = $(rps_test_src) 135test_rps_req_cancel_SOURCES = $(rps_test_src)
144test_rps_req_cancel_LDADD = $(ld_rps_test_lib) 136test_rps_req_cancel_LDADD = $(ld_rps_test_lib)
145 137
138test_rps_sub_SOURCES = $(rps_test_src)
139test_rps_sub_LDADD = $(ld_rps_test_lib)
140
146test_rps_seed_big_SOURCES = $(rps_test_src) 141test_rps_seed_big_SOURCES = $(rps_test_src)
147test_rps_seed_big_LDADD = $(ld_rps_test_lib) 142test_rps_seed_big_LDADD = $(ld_rps_test_lib)
148 143
149test_rps_churn_SOURCES = $(rps_test_src) 144test_rps_churn_SOURCES = $(rps_test_src)
150test_rps_churn_LDADD = $(ld_rps_test_lib) 145test_rps_churn_LDADD = $(ld_rps_test_lib)
151 146
147test_rps_malicious_1_SOURCES = $(rps_test_src)
148test_rps_malicious_1_LDADD = $(ld_rps_test_lib)
149
150test_rps_malicious_2_SOURCES = $(rps_test_src)
151test_rps_malicious_2_LDADD = $(ld_rps_test_lib)
152
153test_rps_malicious_3_SOURCES = $(rps_test_src)
154test_rps_malicious_3_LDADD = $(ld_rps_test_lib)
155
152gnunet_rps_profiler_SOURCES = \ 156gnunet_rps_profiler_SOURCES = \
153 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \ 157 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
154 rps-sampler_common.h rps-sampler_common.c \ 158 rps-sampler_common.h rps-sampler_common.c \