aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am96
1 files changed, 47 insertions, 49 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
index 8f7c104f9..0dddd9726 100644
--- a/src/rps/Makefile.am
+++ b/src/rps/Makefile.am
@@ -45,8 +45,8 @@ libgnunetrps_la_CFLAGS = $(AM_CFLAGS)
45libexec_PROGRAMS = \ 45libexec_PROGRAMS = \
46 gnunet-service-rps 46 gnunet-service-rps
47 47
48noinst_PROGRAMS = \ 48#noinst_PROGRAMS = \
49 gnunet-rps-profiler 49# gnunet-rps-profiler
50 50
51 51
52gnunet_service_rps_SOURCES = \ 52gnunet_service_rps_SOURCES = \
@@ -95,12 +95,12 @@ rps_test_src = \
95 rps-sampler_common.h rps-sampler_common.c \ 95 rps-sampler_common.h rps-sampler_common.c \
96 gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c 96 gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c
97 97
98ld_rps_test_lib = \ 98#ld_rps_test_lib = \
99 libgnunetrps.la \ 99# libgnunetrps.la \
100 $(top_builddir)/src/util/libgnunetutil.la \ 100# $(top_builddir)/src/util/libgnunetutil.la \
101 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 101# $(top_builddir)/src/statistics/libgnunetstatistics.la \
102 $(top_builddir)/src/testbed/libgnunettestbed.la \ 102# $(top_builddir)/src/testbed/libgnunettestbed.la \
103 -lm 103# -lm
104 104
105if ENABLE_TEST_RUN 105if ENABLE_TEST_RUN
106AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 106AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
@@ -124,47 +124,45 @@ test_service_rps_sampler_elem_SOURCES = \
124 test_service_rps_sampler_elem.c 124 test_service_rps_sampler_elem.c
125test_service_rps_sampler_elem_LDADD = $(top_builddir)/src/util/libgnunetutil.la 125test_service_rps_sampler_elem_LDADD = $(top_builddir)/src/util/libgnunetutil.la
126 126
127test_rps_single_req_SOURCES = $(rps_test_src) 127#test_rps_single_req_SOURCES = $(rps_test_src)
128test_rps_single_req_LDADD = $(ld_rps_test_lib) 128#test_rps_single_req_LDADD = $(ld_rps_test_lib)
129 129#
130test_rps_seed_request_SOURCES = $(rps_test_src) 130#test_rps_seed_request_SOURCES = $(rps_test_src)
131test_rps_seed_request_LDADD = $(ld_rps_test_lib) 131#test_rps_seed_request_LDADD = $(ld_rps_test_lib)
132 132#
133test_rps_req_cancel_SOURCES = $(rps_test_src) 133#test_rps_req_cancel_SOURCES = $(rps_test_src)
134test_rps_req_cancel_LDADD = $(ld_rps_test_lib) 134#test_rps_req_cancel_LDADD = $(ld_rps_test_lib)
135 135#
136test_rps_sub_SOURCES = $(rps_test_src) 136#test_rps_sub_SOURCES = $(rps_test_src)
137test_rps_sub_LDADD = $(ld_rps_test_lib) 137#test_rps_sub_LDADD = $(ld_rps_test_lib)
138 138#
139test_rps_seed_big_SOURCES = $(rps_test_src) 139#test_rps_seed_big_SOURCES = $(rps_test_src)
140test_rps_seed_big_LDADD = $(ld_rps_test_lib) 140#test_rps_seed_big_LDADD = $(ld_rps_test_lib)
141 141#
142test_rps_churn_SOURCES = $(rps_test_src) 142#test_rps_churn_SOURCES = $(rps_test_src)
143test_rps_churn_LDADD = $(ld_rps_test_lib) 143#test_rps_churn_LDADD = $(ld_rps_test_lib)
144 144#
145test_rps_malicious_1_SOURCES = $(rps_test_src) 145#test_rps_malicious_1_SOURCES = $(rps_test_src)
146test_rps_malicious_1_LDADD = $(ld_rps_test_lib) 146#test_rps_malicious_1_LDADD = $(ld_rps_test_lib)
147 147#
148test_rps_malicious_2_SOURCES = $(rps_test_src) 148#test_rps_malicious_2_SOURCES = $(rps_test_src)
149test_rps_malicious_2_LDADD = $(ld_rps_test_lib) 149#test_rps_malicious_2_LDADD = $(ld_rps_test_lib)
150 150#
151test_rps_malicious_3_SOURCES = $(rps_test_src) 151#test_rps_malicious_3_SOURCES = $(rps_test_src)
152test_rps_malicious_3_LDADD = $(ld_rps_test_lib) 152#test_rps_malicious_3_LDADD = $(ld_rps_test_lib)
153 153
154gnunet_rps_profiler_SOURCES = \ 154#gnunet_rps_profiler_SOURCES = \
155 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \ 155# gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
156 rps-sampler_common.h rps-sampler_common.c \ 156# rps-sampler_common.h rps-sampler_common.c \
157 gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c \ 157# gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c \
158 rps-test_util.h rps-test_util.c \ 158# rps-test_util.h rps-test_util.c \
159 gnunet-rps-profiler.c 159# gnunet-rps-profiler.c
160 160#gnunet_rps_profiler_LDADD = \
161 161# $(top_builddir)/src/statistics/libgnunetstatistics.la \
162gnunet_rps_profiler_LDADD = \ 162# libgnunetrps.la \
163 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 163# $(top_builddir)/src/util/libgnunetutil.la \
164 libgnunetrps.la \ 164# $(top_builddir)/src/testbed/libgnunettestbed.la \
165 $(top_builddir)/src/util/libgnunetutil.la \ 165# -lm
166 $(top_builddir)/src/testbed/libgnunettestbed.la \
167 -lm
168 166
169 167
170EXTRA_DIST = \ 168EXTRA_DIST = \