aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
index db3174a82..bf34a29d7 100644
--- a/src/rps/Makefile.am
+++ b/src/rps/Makefile.am
@@ -20,7 +20,7 @@ gnunet_rps_SOURCES = \
20 20
21gnunet_rps_LDADD = \ 21gnunet_rps_LDADD = \
22 libgnunetrps.la \ 22 libgnunetrps.la \
23 $(top_builddir)/src/util/libgnunetutil.la \ 23 $(top_builddir)/src/lib/util/libgnunetutil.la \
24 $(XLIB) $(GN_LIBINTL) 24 $(XLIB) $(GN_LIBINTL)
25 25
26lib_LTLIBRARIES = libgnunetrps.la 26lib_LTLIBRARIES = libgnunetrps.la
@@ -33,7 +33,7 @@ libgnunetrps_la_SOURCES = \
33 rps_api.c rps.h 33 rps_api.c rps.h
34libgnunetrps_la_LIBADD = \ 34libgnunetrps_la_LIBADD = \
35 $(top_builddir)/src/nse/libgnunetnse.la \ 35 $(top_builddir)/src/nse/libgnunetnse.la \
36 $(top_builddir)/src/util/libgnunetutil.la \ 36 $(top_builddir)/src/lib/util/libgnunetutil.la \
37 $(GN_LIBINTL) $(XLIB) 37 $(GN_LIBINTL) $(XLIB)
38libgnunetrps_la_LDFLAGS = \ 38libgnunetrps_la_LDFLAGS = \
39 $(GN_LIB_LDFLAGS) \ 39 $(GN_LIB_LDFLAGS) \
@@ -60,7 +60,7 @@ gnunet_service_rps_SOURCES = \
60 60
61gnunet_service_rps_LDADD = \ 61gnunet_service_rps_LDADD = \
62 libgnunetrps.la \ 62 libgnunetrps.la \
63 $(top_builddir)/src/util/libgnunetutil.la \ 63 $(top_builddir)/src/lib/util/libgnunetutil.la \
64 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \ 64 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
65 $(top_builddir)/src/cadet/libgnunetcadet.la \ 65 $(top_builddir)/src/cadet/libgnunetcadet.la \
66 $(top_builddir)/src/nse/libgnunetnse.la \ 66 $(top_builddir)/src/nse/libgnunetnse.la \
@@ -95,7 +95,7 @@ rps_test_src = \
95 95
96#ld_rps_test_lib = \ 96#ld_rps_test_lib = \
97# libgnunetrps.la \ 97# libgnunetrps.la \
98# $(top_builddir)/src/util/libgnunetutil.la \ 98# $(top_builddir)/src/lib/util/libgnunetutil.la \
99# $(top_builddir)/src/statistics/libgnunetstatistics.la \ 99# $(top_builddir)/src/statistics/libgnunetstatistics.la \
100# $(top_builddir)/src/testbed/libgnunettestbed.la \ 100# $(top_builddir)/src/testbed/libgnunettestbed.la \
101# -lm 101# -lm
@@ -108,19 +108,19 @@ endif
108test_service_rps_view_SOURCES = \ 108test_service_rps_view_SOURCES = \
109 gnunet-service-rps_view.h gnunet-service-rps_view.c \ 109 gnunet-service-rps_view.h gnunet-service-rps_view.c \
110 test_service_rps_view.c 110 test_service_rps_view.c
111test_service_rps_view_LDADD = $(top_builddir)/src/util/libgnunetutil.la 111test_service_rps_view_LDADD = $(top_builddir)/src/lib/util/libgnunetutil.la
112 112
113test_service_rps_custommap_SOURCES = \ 113test_service_rps_custommap_SOURCES = \
114 gnunet-service-rps_custommap.h gnunet-service-rps_custommap.c \ 114 gnunet-service-rps_custommap.h gnunet-service-rps_custommap.c \
115 test_service_rps_custommap.c 115 test_service_rps_custommap.c
116test_service_rps_custommap_LDADD = \ 116test_service_rps_custommap_LDADD = \
117 $(top_builddir)/src/util/libgnunetutil.la 117 $(top_builddir)/src/lib/util/libgnunetutil.la
118 118
119test_service_rps_sampler_elem_SOURCES = \ 119test_service_rps_sampler_elem_SOURCES = \
120 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \ 120 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
121 rps-test_util.h rps-test_util.c \ 121 rps-test_util.h rps-test_util.c \
122 test_service_rps_sampler_elem.c 122 test_service_rps_sampler_elem.c
123test_service_rps_sampler_elem_LDADD = $(top_builddir)/src/util/libgnunetutil.la 123test_service_rps_sampler_elem_LDADD = $(top_builddir)/src/lib/util/libgnunetutil.la
124 124
125#test_rps_single_req_SOURCES = $(rps_test_src) 125#test_rps_single_req_SOURCES = $(rps_test_src)
126#test_rps_single_req_LDADD = $(ld_rps_test_lib) 126#test_rps_single_req_LDADD = $(ld_rps_test_lib)
@@ -158,7 +158,7 @@ test_service_rps_sampler_elem_LDADD = $(top_builddir)/src/util/libgnunetutil.la
158#gnunet_rps_profiler_LDADD = \ 158#gnunet_rps_profiler_LDADD = \
159# $(top_builddir)/src/statistics/libgnunetstatistics.la \ 159# $(top_builddir)/src/statistics/libgnunetstatistics.la \
160# libgnunetrps.la \ 160# libgnunetrps.la \
161# $(top_builddir)/src/util/libgnunetutil.la \ 161# $(top_builddir)/src/lib/util/libgnunetutil.la \
162# $(top_builddir)/src/testbed/libgnunettestbed.la \ 162# $(top_builddir)/src/testbed/libgnunettestbed.la \
163# -lm 163# -lm
164 164