aboutsummaryrefslogtreecommitdiff
path: root/src/service/core/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/core/Makefile.am')
-rw-r--r--src/service/core/Makefile.am128
1 files changed, 128 insertions, 0 deletions
diff --git a/src/service/core/Makefile.am b/src/service/core/Makefile.am
new file mode 100644
index 000000000..6de6762b1
--- /dev/null
+++ b/src/service/core/Makefile.am
@@ -0,0 +1,128 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6plugindir = $(libdir)/gnunet
7
8libexecdir= $(pkglibdir)/libexec/
9
10pkgcfg_DATA = \
11 core.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = --coverage -O0
15 XLIB = -lgcov
16endif
17
18#plugin_LTLIBRARIES = \
19# libgnunet_test_core_plugin_cmd_just_run.la
20
21lib_LTLIBRARIES = \
22 libgnunetcore.la
23# libgnunettestingcore.la
24
25libgnunetcore_la_SOURCES = \
26 core_api.c core.h \
27 core_api_monitor_peers.c
28libgnunetcore_la_LIBADD = \
29 $(top_builddir)/src/lib/util/libgnunetutil.la \
30 $(GN_LIBINTL) $(XLIB)
31libgnunetcore_la_LDFLAGS = \
32 $(GN_LIB_LDFLAGS) \
33 -version-info 0:1:0
34
35libgnunet_test_core_plugin_cmd_just_run_la_SOURCES = \
36 test_core_plugin_cmd_just_run.c
37libgnunet_test_core_plugin_cmd_just_run_la_LIBADD = \
38 libgnunettestingcore.la \
39 $(top_builddir)/src/service/transport/libgnunettestingtransport.la \
40 $(top_builddir)/src/lib/testing/libgnunettesting.la \
41 $(top_builddir)/src/service/transport/libgnunettransportapplication.la \
42 $(top_builddir)/src/service/transport/libgnunettransportcore.la \
43 $(top_builddir)/src/lib/hello/libgnunethello.la \
44 $(top_builddir)/src/service/peerstore/libgnunetpeerstore.la \
45 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
46 $(top_builddir)/src/service/arm/libgnunetarm.la \
47 $(top_builddir)/src/lib/util/libgnunetutil.la \
48 $(LTLIBINTL)
49libgnunet_test_core_plugin_cmd_just_run_la_LDFLAGS = \
50 $(GN_PLUGIN_LDFLAGS)
51
52libgnunettestingcore_la_SOURCES = \
53 testing_core_cmd_connecting_peers.c
54libgnunettestingcore_la_LIBADD = \
55 $(top_builddir)/src/lib/testing/libgnunettesting.la \
56 $(top_builddir)/src/service/transport/libgnunettestingtransport.la \
57 $(top_builddir)/src/service/arm/libgnunetarm.la \
58 $(top_builddir)/src/service/transport/libgnunettransportapplication.la \
59 $(top_builddir)/src/lib/hello/libgnunethello.la \
60 $(top_builddir)/src/service/peerstore/libgnunetpeerstore.la \
61 $(top_builddir)/src/service/transport/libgnunettransportcore.la \
62 $(top_builddir)/src/lib/util/libgnunetutil.la
63libgnunettestingcore_la_LDFLAGS = \
64 $(GN_LIBINTL) \
65 $(GN_LIB_LDFLAGS) \
66 -version-info 0:0:0
67
68
69libexec_PROGRAMS = \
70 gnunet-service-core
71
72gnunet_service_core_SOURCES = \
73 gnunet-service-core.c gnunet-service-core.h \
74 gnunet-service-core_kx.c gnunet-service-core_kx.h \
75 gnunet-service-core_sessions.c gnunet-service-core_sessions.h \
76 gnunet-service-core_typemap.c gnunet-service-core_typemap.h
77gnunet_service_core_LDADD = \
78 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
79 $(top_builddir)/src/service/transport/libgnunettransportapplication.la \
80 $(top_builddir)/src/service/transport/libgnunettransportcore.la \
81 $(top_builddir)/src/lib/util/libgnunetutil.la \
82 $(GN_LIBINTL) $(Z_LIBS)
83
84
85#TESTING_TESTS = \
86# test_core_api_send_to_self
87
88check_PROGRAMS = \
89 test_core_api_start_only \
90 $(TESTING_TESTS)
91
92# Only test TNG if we run experimental
93#check_SCRIPTS= \
94# test_core_start_testcase.sh
95
96if ENABLE_TEST_RUN
97AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
98TESTS = $(check_PROGRAMS) \
99 $(check_SCRIPTS)
100endif
101
102test_core_api_send_to_self_SOURCES = \
103 test_core_api_send_to_self.c
104test_core_api_send_to_self_LDADD = \
105 libgnunetcore.la \
106 $(top_builddir)/src/lib/testing/libgnunettesting.la \
107 $(top_builddir)/src/lib/util/libgnunetutil.la
108
109test_core_api_start_only_SOURCES = \
110 test_core_api_start_only.c
111test_core_api_start_only_LDADD = \
112 $(top_builddir)/src/lib/testing/libgnunettesting.la \
113 libgnunetcore.la \
114 $(top_builddir)/src/lib/util/libgnunetutil.la
115
116EXTRA_DIST = \
117 test_core_start_testcase.sh \
118 test_core_defaults.conf \
119 test_core_api_data.conf \
120 test_core_api_peer1.conf \
121 test_core_api_peer2.conf \
122 test_core_api_send_to_self.conf \
123 test_core_quota_asymmetric_recv_limited_peer1.conf \
124 test_core_quota_asymmetric_recv_limited_peer2.conf \
125 test_core_quota_asymmetric_send_limit_peer1.conf \
126 test_core_quota_asymmetric_send_limit_peer2.conf \
127 test_core_quota_peer1.conf \
128 test_core_quota_peer2.conf