diff options
Diffstat (limited to 'src/service/core/Makefile.am')
-rw-r--r-- | src/service/core/Makefile.am | 127 |
1 files changed, 127 insertions, 0 deletions
diff --git a/src/service/core/Makefile.am b/src/service/core/Makefile.am new file mode 100644 index 000000000..9ce8cf8b5 --- /dev/null +++ b/src/service/core/Makefile.am | |||
@@ -0,0 +1,127 @@ | |||
1 | # This Makefile.am is in the public domain | ||
2 | AM_CPPFLAGS = -I$(top_srcdir)/src/include | ||
3 | |||
4 | pkgcfgdir= $(pkgdatadir)/config.d/ | ||
5 | |||
6 | plugindir = $(libdir)/gnunet | ||
7 | |||
8 | libexecdir= $(pkglibdir)/libexec/ | ||
9 | |||
10 | pkgcfg_DATA = \ | ||
11 | core.conf | ||
12 | |||
13 | if USE_COVERAGE | ||
14 | AM_CFLAGS = --coverage -O0 | ||
15 | XLIB = -lgcov | ||
16 | endif | ||
17 | |||
18 | plugin_LTLIBRARIES = \ | ||
19 | libgnunet_test_core_plugin_cmd_just_run.la | ||
20 | |||
21 | TESTING_LIBS = \ | ||
22 | libgnunetcoretesting.la | ||
23 | |||
24 | lib_LTLIBRARIES = \ | ||
25 | libgnunetcore.la \ | ||
26 | $(TESTING_LIBS) | ||
27 | |||
28 | libgnunetcore_la_SOURCES = \ | ||
29 | core_api.c core.h \ | ||
30 | core_api_monitor_peers.c | ||
31 | libgnunetcore_la_LIBADD = \ | ||
32 | $(top_builddir)/src/lib/util/libgnunetutil.la \ | ||
33 | $(GN_LIBINTL) $(XLIB) | ||
34 | libgnunetcore_la_LDFLAGS = \ | ||
35 | $(GN_LIB_LDFLAGS) \ | ||
36 | -version-info 0:1:0 | ||
37 | |||
38 | libgnunet_test_core_plugin_cmd_just_run_la_SOURCES = \ | ||
39 | test_core_plugin_cmd_just_run.c | ||
40 | libgnunet_test_core_plugin_cmd_just_run_la_LIBADD = \ | ||
41 | libgnunetcoretesting.la \ | ||
42 | $(top_builddir)/src/transport/libgnunettransportapplication.la \ | ||
43 | $(top_builddir)/src/transport/libgnunettransportcore.la \ | ||
44 | $(top_builddir)/src/lib/testing/libgnunettesting.la \ | ||
45 | $(top_builddir)/src/peerstore/libgnunetpeerstore.la \ | ||
46 | $(top_builddir)/src/statistics/libgnunetstatistics.la \ | ||
47 | $(top_builddir)/src/lib/hello/libgnunethello.la \ | ||
48 | $(top_builddir)/src/service/arm/libgnunetarm.la \ | ||
49 | $(top_builddir)/src/lib/util/libgnunetutil.la \ | ||
50 | $(LTLIBINTL) | ||
51 | libgnunet_test_core_plugin_cmd_just_run_la_LDFLAGS = \ | ||
52 | $(GN_PLUGIN_LDFLAGS) | ||
53 | |||
54 | libgnunetcoretesting_la_SOURCES = \ | ||
55 | core_api_cmd_connecting_peers.c | ||
56 | libgnunetcoretesting_la_LIBADD = \ | ||
57 | $(top_builddir)/src/lib/testing/libgnunettesting.la \ | ||
58 | $(top_builddir)/src/service/arm/libgnunetarm.la \ | ||
59 | $(top_builddir)/src/transport/libgnunettransportapplication.la \ | ||
60 | $(top_builddir)/src/transport/libgnunettransportcore.la \ | ||
61 | $(top_builddir)/src/lib/util/libgnunetutil.la | ||
62 | libgnunetcoretesting_la_LDFLAGS = \ | ||
63 | $(GN_LIBINTL) \ | ||
64 | $(GN_LIB_LDFLAGS) \ | ||
65 | -version-info 0:0:0 | ||
66 | |||
67 | |||
68 | libexec_PROGRAMS = \ | ||
69 | gnunet-service-core | ||
70 | |||
71 | gnunet_service_core_SOURCES = \ | ||
72 | gnunet-service-core.c gnunet-service-core.h \ | ||
73 | gnunet-service-core_kx.c gnunet-service-core_kx.h \ | ||
74 | gnunet-service-core_sessions.c gnunet-service-core_sessions.h \ | ||
75 | gnunet-service-core_typemap.c gnunet-service-core_typemap.h | ||
76 | gnunet_service_core_LDADD = \ | ||
77 | $(top_builddir)/src/statistics/libgnunetstatistics.la \ | ||
78 | $(top_builddir)/src/transport/libgnunettransportapplication.la \ | ||
79 | $(top_builddir)/src/transport/libgnunettransportcore.la \ | ||
80 | $(top_builddir)/src/lib/util/libgnunetutil.la \ | ||
81 | $(GN_LIBINTL) $(Z_LIBS) | ||
82 | |||
83 | |||
84 | TESTING_TESTS = \ | ||
85 | test_core_api_send_to_self | ||
86 | |||
87 | check_PROGRAMS = \ | ||
88 | test_core_api_start_only \ | ||
89 | $(TESTING_TESTS) | ||
90 | |||
91 | # Only test TNG if we run experimental | ||
92 | check_SCRIPTS= \ | ||
93 | test_core_start_testcase.sh | ||
94 | |||
95 | if ENABLE_TEST_RUN | ||
96 | AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; | ||
97 | TESTS = $(check_PROGRAMS) \ | ||
98 | $(check_SCRIPTS) | ||
99 | endif | ||
100 | |||
101 | test_core_api_send_to_self_SOURCES = \ | ||
102 | test_core_api_send_to_self.c | ||
103 | test_core_api_send_to_self_LDADD = \ | ||
104 | libgnunetcore.la \ | ||
105 | $(top_builddir)/src/lib/testing/libgnunettesting.la \ | ||
106 | $(top_builddir)/src/lib/util/libgnunetutil.la | ||
107 | |||
108 | test_core_api_start_only_SOURCES = \ | ||
109 | test_core_api_start_only.c | ||
110 | test_core_api_start_only_LDADD = \ | ||
111 | $(top_builddir)/src/lib/testing/libgnunettesting.la \ | ||
112 | libgnunetcore.la \ | ||
113 | $(top_builddir)/src/lib/util/libgnunetutil.la | ||
114 | |||
115 | EXTRA_DIST = \ | ||
116 | test_core_start_testcase.sh \ | ||
117 | test_core_defaults.conf \ | ||
118 | test_core_api_data.conf \ | ||
119 | test_core_api_peer1.conf \ | ||
120 | test_core_api_peer2.conf \ | ||
121 | test_core_api_send_to_self.conf \ | ||
122 | test_core_quota_asymmetric_recv_limited_peer1.conf \ | ||
123 | test_core_quota_asymmetric_recv_limited_peer2.conf \ | ||
124 | test_core_quota_asymmetric_send_limit_peer1.conf \ | ||
125 | test_core_quota_asymmetric_send_limit_peer2.conf \ | ||
126 | test_core_quota_peer1.conf \ | ||
127 | test_core_quota_peer2.conf | ||