aboutsummaryrefslogtreecommitdiff
path: root/src/service/datacache/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/datacache/Makefile.am')
-rw-r--r--src/service/datacache/Makefile.am104
1 files changed, 104 insertions, 0 deletions
diff --git a/src/service/datacache/Makefile.am b/src/service/datacache/Makefile.am
new file mode 100644
index 000000000..022b45253
--- /dev/null
+++ b/src/service/datacache/Makefile.am
@@ -0,0 +1,104 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8dist_pkgcfg_DATA = \
9 datacache.conf
10
11if USE_COVERAGE
12 AM_CFLAGS = --coverage -O0
13 XLIBS = -lgcov
14endif
15
16lib_LTLIBRARIES = \
17 libgnunetdatacache.la
18
19libgnunetdatacache_la_SOURCES = \
20 datacache.c
21libgnunetdatacache_la_LIBADD = \
22 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
23 $(top_builddir)/src/lib/util/libgnunetutil.la \
24 $(GN_LIBINTL)
25libgnunetdatacache_la_LDFLAGS = \
26 $(GN_LIB_LDFLAGS) \
27 -version-info 0:1:0
28
29
30if HAVE_SQLITE
31SQLITE_TESTS = \
32 test_datacache_sqlite \
33 test_datacache_quota_sqlite \
34 $(SQLITE_BENCHMARKS)
35endif
36
37HEAP_TESTS = \
38 test_datacache_heap \
39 test_datacache_quota_heap \
40 $(HEAP_BENCHMARKS)
41
42if HAVE_POSTGRESQL
43POSTGRES_TESTS = \
44 test_datacache_postgres \
45 test_datacache_quota_postgres \
46 $(POSTGRES_BENCHMARKS)
47endif
48
49check_PROGRAMS = \
50 $(SQLITE_TESTS) \
51 $(HEAP_TESTS) \
52 $(POSTGRES_TESTS)
53
54if ENABLE_TEST_RUN
55AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
56TESTS = $(check_PROGRAMS)
57endif
58
59test_datacache_sqlite_SOURCES = \
60 test_datacache.c
61test_datacache_sqlite_LDADD = \
62 $(top_builddir)/src/service/testing/libgnunettesting.la \
63 libgnunetdatacache.la \
64 $(top_builddir)/src/lib/util/libgnunetutil.la
65
66test_datacache_quota_sqlite_SOURCES = \
67 test_datacache_quota.c
68test_datacache_quota_sqlite_LDADD = \
69 $(top_builddir)/src/service/testing/libgnunettesting.la \
70 libgnunetdatacache.la \
71 $(top_builddir)/src/lib/util/libgnunetutil.la
72
73test_datacache_heap_SOURCES = \
74 test_datacache.c
75test_datacache_heap_LDADD = \
76 $(top_builddir)/src/service/testing/libgnunettesting.la \
77 libgnunetdatacache.la \
78 $(top_builddir)/src/lib/util/libgnunetutil.la
79
80test_datacache_quota_heap_SOURCES = \
81 test_datacache_quota.c
82test_datacache_quota_heap_LDADD = \
83 $(top_builddir)/src/service/testing/libgnunettesting.la \
84 libgnunetdatacache.la \
85 $(top_builddir)/src/lib/util/libgnunetutil.la
86
87test_datacache_postgres_SOURCES = \
88 test_datacache.c
89test_datacache_postgres_LDADD = \
90 $(top_builddir)/src/service/testing/libgnunettesting.la \
91 libgnunetdatacache.la \
92 $(top_builddir)/src/lib/util/libgnunetutil.la
93
94test_datacache_quota_postgres_SOURCES = \
95 test_datacache_quota.c
96test_datacache_quota_postgres_LDADD = \
97 $(top_builddir)/src/service/testing/libgnunettesting.la \
98 libgnunetdatacache.la \
99 $(top_builddir)/src/lib/util/libgnunetutil.la
100
101EXTRA_DIST = \
102 test_datacache_data_sqlite.conf \
103 test_datacache_data_heap.conf \
104 test_datacache_data_postgres.conf