aboutsummaryrefslogtreecommitdiff
path: root/src/service/datacache/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/datacache/meson.build')
-rw-r--r--src/service/datacache/meson.build109
1 files changed, 109 insertions, 0 deletions
diff --git a/src/service/datacache/meson.build b/src/service/datacache/meson.build
new file mode 100644
index 000000000..f50036c03
--- /dev/null
+++ b/src/service/datacache/meson.build
@@ -0,0 +1,109 @@
1libgnunetdatacache_src = ['datacache.c']
2
3configure_file(input : 'datacache.conf',
4 output : 'datacache.conf',
5 configuration : cdata,
6 install: true,
7 install_dir: pkgcfgdir)
8
9if get_option('monolith')
10 foreach p : libgnunetdatacache_src
11 gnunet_src += 'datacache/' + p
12 endforeach
13endif
14
15libgnunetdatacache = library('gnunetdatacache',
16 libgnunetdatacache_src,
17 soversion: '0',
18 version: '0.0.1',
19 dependencies: [libgnunetutil_dep, libgnunetstatistics_dep],
20 include_directories: [incdir, configuration_inc],
21 install: true,
22 install_dir: get_option('libdir'))
23libgnunetdatacache_dep = declare_dependency(link_with : libgnunetdatacache)
24pkg.generate(libgnunetdatacache, url: 'https://www.gnunet.org',
25 description : 'Provides datacache API for temporary storage to disk')
26
27testdc_sqlite = executable ('test_datacache_sqlite',
28 ['test_datacache.c'],
29 dependencies: [
30 libgnunetdatacache_dep,
31 libgnunetutil_dep,
32 libgnunettesting_dep
33 ],
34 include_directories: [incdir, configuration_inc],
35 install: false)
36
37testdc_quota_sqlite = executable ('test_datacache_quota_sqlite',
38 ['test_datacache_quota.c'],
39 dependencies: [
40 libgnunetdatacache_dep,
41 libgnunetutil_dep,
42 libgnunettesting_dep
43 ],
44 include_directories: [incdir, configuration_inc],
45 install: false)
46
47testdc_heap = executable ('test_datacache_heap',
48 ['test_datacache.c'],
49 dependencies: [
50 libgnunetdatacache_dep,
51 libgnunetutil_dep,
52 libgnunettesting_dep
53 ],
54 include_directories: [incdir, configuration_inc],
55 install: false)
56
57testdc_quota_heap = executable ('test_datacache_quota_heap',
58 ['test_datacache_quota.c'],
59 dependencies: [
60 libgnunetdatacache_dep,
61 libgnunetutil_dep,
62 libgnunettesting_dep
63 ],
64 include_directories: [incdir, configuration_inc],
65 install: false)
66
67
68testdc_pq = executable ('test_datacache_postgres',
69 ['test_datacache.c'],
70 dependencies: [
71 libgnunetdatacache_dep,
72 libgnunetutil_dep,
73 libgnunettesting_dep
74 ],
75 include_directories: [incdir, configuration_inc],
76 install: false)
77
78testdc_quota_pq = executable ('test_datacache_quota_postgres',
79 ['test_datacache_quota.c'],
80 dependencies: [
81 libgnunetdatacache_dep,
82 libgnunetutil_dep,
83 libgnunettesting_dep
84 ],
85 include_directories: [incdir, configuration_inc],
86 install: false)
87
88configure_file(input : 'test_datacache_data_sqlite.conf',
89 output : 'test_datacache_data_sqlite.conf',
90 copy: true)
91configure_file(input : 'test_datacache_data_heap.conf',
92 output : 'test_datacache_data_heap.conf',
93 copy: true)
94configure_file(input : 'test_datacache_data_postgres.conf',
95 output : 'test_datacache_data_postgres.conf',
96 copy: true)
97
98test('test_datacache_sqlite', testdc_sqlite,
99 suite: 'datacache', workdir: meson.current_build_dir())
100test('test_datacache_quota_sqlite', testdc_quota_sqlite,
101 suite: 'datacache', workdir: meson.current_build_dir())
102test('test_datacache_heap', testdc_heap,
103 suite: 'datacache', workdir: meson.current_build_dir())
104test('test_datacache_quota_heap', testdc_quota_heap,
105 suite: 'datacache', workdir: meson.current_build_dir())
106test('test_datacache_postgres', testdc_pq,
107 suite: 'datacache', workdir: meson.current_build_dir())
108test('test_datacache_quota_postgres', testdc_quota_pq,
109 suite: 'datacache', workdir: meson.current_build_dir())