aboutsummaryrefslogtreecommitdiff
path: root/src/service/datacache/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/datacache/meson.build')
-rw-r--r--src/service/datacache/meson.build33
1 files changed, 0 insertions, 33 deletions
diff --git a/src/service/datacache/meson.build b/src/service/datacache/meson.build
index 528885c0d..f50036c03 100644
--- a/src/service/datacache/meson.build
+++ b/src/service/datacache/meson.build
@@ -5,9 +5,6 @@ configure_file(input : 'datacache.conf',
5 configuration : cdata, 5 configuration : cdata,
6 install: true, 6 install: true,
7 install_dir: pkgcfgdir) 7 install_dir: pkgcfgdir)
8install_data ('datacache-0001.sql',
9 'datacache-drop.sql',
10 install_dir: get_option('datadir')/'gnunet'/'sql')
11 8
12if get_option('monolith') 9if get_option('monolith')
13 foreach p : libgnunetdatacache_src 10 foreach p : libgnunetdatacache_src
@@ -27,36 +24,6 @@ libgnunetdatacache_dep = declare_dependency(link_with : libgnunetdatacache)
27pkg.generate(libgnunetdatacache, url: 'https://www.gnunet.org', 24pkg.generate(libgnunetdatacache, url: 'https://www.gnunet.org',
28 description : 'Provides datacache API for temporary storage to disk') 25 description : 'Provides datacache API for temporary storage to disk')
29 26
30shared_module('gnunet_plugin_datacache_sqlite',
31 ['plugin_datacache_sqlite.c'],
32 dependencies: [libgnunetutil_dep,
33 libgnunetdatacache_dep,
34 sqlite_dep,
35 libgnunetsq_dep],
36 include_directories: [incdir, configuration_inc],
37 install: true,
38 install_dir: get_option('libdir')/'gnunet')
39
40shared_module('gnunet_plugin_datacache_heap',
41 ['plugin_datacache_heap.c'],
42 dependencies: [libgnunetutil_dep,
43 libgnunetdatacache_dep],
44 include_directories: [incdir, configuration_inc],
45 install: true,
46 install_dir: get_option('libdir')/'gnunet')
47
48if pq_dep.found()
49 shared_module('gnunet_plugin_datacache_postgres',
50 ['plugin_datacache_postgres.c'],
51 dependencies: [libgnunetutil_dep,
52 libgnunetdatacache_dep,
53 pq_dep,
54 libgnunetpq_dep],
55 include_directories: [incdir, configuration_inc],
56 install: true,
57 install_dir: get_option('libdir')/'gnunet')
58endif
59
60testdc_sqlite = executable ('test_datacache_sqlite', 27testdc_sqlite = executable ('test_datacache_sqlite',
61 ['test_datacache.c'], 28 ['test_datacache.c'],
62 dependencies: [ 29 dependencies: [