aboutsummaryrefslogtreecommitdiff
path: root/src/service/exit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/exit/Makefile.am')
-rw-r--r--src/service/exit/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/service/exit/Makefile.am b/src/service/exit/Makefile.am
new file mode 100644
index 000000000..524fe19fa
--- /dev/null
+++ b/src/service/exit/Makefile.am
@@ -0,0 +1,38 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6endif
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10libexecdir= $(pkglibdir)/libexec/
11
12plugindir = $(libdir)/gnunet
13
14dist_pkgcfg_DATA = \
15 exit.conf
16
17if LINUX
18EXITBIN = gnunet-helper-exit
19endif
20
21
22libexec_PROGRAMS = \
23 gnunet-daemon-exit \
24 $(EXITBIN)
25
26
27gnunet_helper_exit_SOURCES = \
28 gnunet-helper-exit.c
29
30gnunet_daemon_exit_SOURCES = \
31 gnunet-daemon-exit.c exit.h
32gnunet_daemon_exit_LDADD = \
33 $(top_builddir)/src/service/dht/libgnunetdht.la \
34 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
35 $(top_builddir)/src/lib/util/libgnunetutil.la \
36 $(top_builddir)/src/service/cadet/libgnunetcadet.la \
37 $(top_builddir)/src/service/regex/libgnunetregex.la \
38 $(GN_LIBINTL)