aboutsummaryrefslogtreecommitdiff
path: root/src/service/gns/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/gns/Makefile.am')
-rw-r--r--src/service/gns/Makefile.am180
1 files changed, 180 insertions, 0 deletions
diff --git a/src/service/gns/Makefile.am b/src/service/gns/Makefile.am
new file mode 100644
index 000000000..a169b43a6
--- /dev/null
+++ b/src/service/gns/Makefile.am
@@ -0,0 +1,180 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if HAVE_GLIBCNSS
5NSS_SUBDIR = nss
6endif
7
8SUBDIRS = . $(NSS_SUBDIR)
9
10if HAVE_LIBIDN
11 LIBIDN= -lidn
12else
13 LIBIDN=
14endif
15
16if HAVE_LIBIDN2
17 LIBIDN2= -lidn2
18else
19 LIBIDN2=
20endif
21
22USE_VPN = $(top_builddir)/src/service/vpn/libgnunetvpn.la
23
24if USE_COVERAGE
25 AM_CFLAGS = --coverage -O0
26endif
27
28pkgcfgdir = $(pkgdatadir)/config.d/
29
30libexecdir= $(pkglibdir)/libexec/
31
32plugindir = $(libdir)/gnunet
33
34pkgcfg_DATA = \
35 gns.conf
36dist_pkgcfg_DATA = \
37 tlds.conf
38
39lib_LTLIBRARIES = \
40 libgnunetgns.la
41
42libexec_PROGRAMS = \
43 gnunet-service-gns \
44 gnunet-dns2gns
45
46noinst_PROGRAMS = \
47 gnunet-gns-benchmark
48
49if HAVE_PDFLATEX
50libexec_PROGRAMS += gnunet-bcd
51endif
52
53if HAVE_GNUTLS
54libexec_PROGRAMS += gnunet-gns-proxy
55endif
56
57gnunet_gns_benchmark_SOURCES = \
58 gnunet-gns-benchmark.c
59gnunet_gns_benchmark_LDADD = \
60 libgnunetgns.la \
61 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
62 $(top_builddir)/src/service/identity/libgnunetidentity.la \
63 $(top_builddir)/src/lib/util/libgnunetutil.la \
64 $(GN_LIBINTL)
65
66
67gnunet_bcd_SOURCES = \
68 gnunet-bcd.c
69gnunet_bcd_LDADD = \
70 $(top_builddir)/src/lib/util/libgnunetutil.la \
71 $(top_builddir)/src/service/identity/libgnunetidentity.la \
72 $(GN_LIBINTL) $(MHD_LIBS)
73gnunet_bcd_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
74
75
76gnunet_dns2gns_SOURCES = \
77 gnunet-dns2gns.c
78gnunet_dns2gns_LDADD = \
79 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
80 libgnunetgns.la \
81 $(top_builddir)/src/lib/util/libgnunetutil.la \
82 $(USE_VPN) \
83 $(top_builddir)/src/service/identity/libgnunetidentity.la \
84 $(GN_LIBINTL)
85
86if HAVE_SUDO
87SUDO_OR_DOAS_BINARY= $(SUDO_BINARY) -n
88else
89if HAVE_DOAS_BINARY
90SUDO_OR_DOAS_BINARY= $(DOAS_BINARY)
91endif
92endif
93
94if LINUX
95HIJACKBIN = gnunet-dns2gns
96install-exec-hook:
97 $(SUDO_OR_DOAS_BINARY) setcap 'cap_net_bind_service=+ep' $(DESTDIR)$(libexecdir)/gnunet-dns2gns || true
98else
99install-exec-hook:
100endif
101
102gnunet_gns_proxy_SOURCES = \
103 gnunet-gns-proxy.c
104gnunet_gns_proxy_LDADD = $(MHD_LIBS) @LIBCURL@ -lgnutls \
105 libgnunetgns.la \
106 $(top_builddir)/src/service/identity/libgnunetidentity.la \
107 $(top_builddir)/src/lib/util/libgnunetutil.la \
108 $(GN_LIBINTL)
109if HAVE_GNUTLS_DANE
110gnunet_gns_proxy_LDADD += -lgnutls-dane
111endif
112gnunet_gns_proxy_CFLAGS = $(MHD_CFLAGS) @LIBCURL_CPPFLAGS@ $(AM_CFLAGS)
113
114test_gns_proxy_SOURCES = \
115 test_gns_proxy.c
116test_gns_proxy_LDADD = $(MHD_LIBS) @LIBCURL@ -lgnutls \
117 $(top_builddir)/src/lib/util/libgnunetutil.la \
118 $(GN_LIBINTL)
119test_gns_proxy_CFLAGS = $(MHD_CFLAGS) @LIBCURL_CPPFLAGS@ $(AM_CFLAGS)
120
121#gnunet_gns_import_SOURCES = \
122# gnunet-gns-import.c
123#gnunet_gns_import_LDADD = \
124# $(top_builddir)/src/service/identity/libgnunetidentity.la \
125# $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
126# $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
127# $(top_builddir)/src/lib/util/libgnunetutil.la \
128# $(GN_LIBINTL)
129
130
131gnunet_service_gns_SOURCES = \
132 gnunet-service-gns.c gnunet-service-gns.h \
133 gnunet-service-gns_resolver.c gnunet-service-gns_resolver.h \
134 gnunet-service-gns_interceptor.c gnunet-service-gns_interceptor.h
135gnunet_service_gns_LDADD = \
136 -lm \
137 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
138 $(top_builddir)/src/service/identity/libgnunetidentity.la \
139 $(top_builddir)/src/service/revocation/libgnunetrevocation.la \
140 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
141 $(top_builddir)/src/lib/util/libgnunetutil.la \
142 $(top_builddir)/src/service/dns/libgnunetdns.la \
143 $(top_builddir)/src/service/dht/libgnunetdht.la \
144 $(top_builddir)/src/service/namecache/libgnunetnamecache.la \
145 $(LIBIDN) $(LIBIDN2) \
146 $(GN_LIBINTL)
147
148
149libgnunetgns_la_SOURCES = \
150 gns_api.c gns_api.h \
151 gns_tld_api.c gns.h
152libgnunetgns_la_LIBADD = \
153 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIB) \
154 $(top_builddir)/src/service/identity/libgnunetidentity.la \
155 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la
156libgnunetgns_la_LDFLAGS = \
157 $(GN_LIBINTL) \
158 $(GN_LIB_LDFLAGS)
159
160
161if HAVE_GNUTLS
162check_PROGRAMS = \
163 test_gns_proxy
164endif
165
166if HAVE_GNUTLS_CURL
167check_SCRIPTS = \
168 test_proxy.sh
169endif
170
171EXTRA_DIST = \
172 test_gns_proxy.conf \
173 test_proxy.sh
174
175if ENABLE_TEST_RUN
176if HAVE_SQLITE
177 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
178 TESTS = $(check_SCRIPTS)
179endif
180endif