aboutsummaryrefslogtreecommitdiff
path: root/src/service/hostlist/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/hostlist/Makefile.am')
-rw-r--r--src/service/hostlist/Makefile.am82
1 files changed, 82 insertions, 0 deletions
diff --git a/src/service/hostlist/Makefile.am b/src/service/hostlist/Makefile.am
new file mode 100644
index 000000000..fc9952aa6
--- /dev/null
+++ b/src/service/hostlist/Makefile.am
@@ -0,0 +1,82 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8
9if USE_COVERAGE
10 AM_CFLAGS = --coverage -O0
11endif
12
13 HOSTLIST_SERVER_SOURCES = \
14 gnunet-daemon-hostlist_server.c gnunet-daemon-hostlist_server.h
15 GN_LIBMHD = $(MHD_LIBS)
16 GN_CPPMHD = $(MHD_CFLAGS)
17
18libexec_PROGRAMS = \
19 gnunet-daemon-hostlist
20dist_pkgcfg_DATA = \
21 hostlist.conf
22
23gnunet_daemon_hostlist_SOURCES = \
24 gnunet-daemon-hostlist.c gnunet-daemon-hostlist.h \
25 gnunet-daemon-hostlist_client.c gnunet-daemon-hostlist_client.h \
26 $(HOSTLIST_SERVER_SOURCES)
27
28gnunet_daemon_hostlist_LDADD = \
29 $(top_builddir)/src/service/core/libgnunetcore.la \
30 $(top_builddir)/src/lib/hello/libgnunethello.la \
31 $(top_builddir)/src/service/peerstore/libgnunetpeerstore.la \
32 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
33 $(top_builddir)/src/lib/util/libgnunetutil.la \
34 $(GN_LIBMHD) \
35 @LIBCURL@ \
36 $(GN_LIBINTL)
37
38gnunet_daemon_hostlist_CFLAGS = \
39 $(GN_CPPMHD) \
40 @LIBCURL_CPPFLAGS@ \
41 $(AM_CFLAGS)
42
43#check_PROGRAMS = \
44# test_gnunet_daemon_hostlist \
45# test_gnunet_daemon_hostlist_reconnect \
46# test_gnunet_daemon_hostlist_learning
47
48if ENABLE_TEST_RUN
49AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
50TESTS = \
51 $(check_PROGRAMS)
52endif
53
54#test_gnunet_daemon_hostlist_SOURCES = \
55# test_gnunet_daemon_hostlist.c
56#test_gnunet_daemon_hostlist_LDADD = \
57# $(top_builddir)/src/service/transport/libgnunettransport.la \
58# $(top_builddir)/src/lib/util/libgnunetutil.la
59#
60#test_gnunet_daemon_hostlist_reconnect_SOURCES = \
61# test_gnunet_daemon_hostlist_reconnect.c
62#test_gnunet_daemon_hostlist_reconnect_LDADD = \
63# $(top_builddir)/src/service/transport/libgnunettransport.la \
64# $(top_builddir)/src/lib/util/libgnunetutil.la
65#
66#test_gnunet_daemon_hostlist_learning_SOURCES = \
67# test_gnunet_daemon_hostlist_learning.c
68#test_gnunet_daemon_hostlist_learning_LDADD = \
69# $(top_builddir)/src/service/transport/libgnunettransport.la \
70# $(top_builddir)/src/service/core/libgnunetcore.la \
71# $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
72# $(top_builddir)/src/lib/util/libgnunetutil.la
73
74EXTRA_DIST = \
75 test_hostlist_defaults.conf \
76 test_gnunet_daemon_hostlist_data.conf \
77 test_gnunet_daemon_hostlist_peer1.conf \
78 test_gnunet_daemon_hostlist_peer2.conf \
79 test_learning_adv_peer.conf \
80 test_learning_learn_peer.conf \
81 test_learning_learn_peer2.conf \
82 learning_data.conf