aboutsummaryrefslogtreecommitdiff
path: root/src/service/identity/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/identity/Makefile.am')
-rw-r--r--src/service/identity/Makefile.am67
1 files changed, 67 insertions, 0 deletions
diff --git a/src/service/identity/Makefile.am b/src/service/identity/Makefile.am
new file mode 100644
index 000000000..079a9af2e
--- /dev/null
+++ b/src/service/identity/Makefile.am
@@ -0,0 +1,67 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6if USE_COVERAGE
7 AM_CFLAGS = --coverage -O0
8 XLIB = -lgcov
9endif
10
11pkgcfgdir= $(pkgdatadir)/config.d/
12
13libexecdir= $(pkglibdir)/libexec/
14
15pkgcfg_DATA = \
16 identity.conf
17
18lib_LTLIBRARIES = \
19 libgnunetidentity.la
20
21
22libgnunetidentity_la_SOURCES = \
23 identity_api.c \
24 identity_api_lookup.c \
25 identity_api_suffix_lookup.c \
26 identity.h
27libgnunetidentity_la_LIBADD = \
28 $(top_builddir)/src/lib/util/libgnunetutil.la \
29 $(GN_LIBINTL) $(XLIB)
30libgnunetidentity_la_LDFLAGS = \
31 $(GN_LIB_LDFLAGS) \
32 -lsodium \
33 -version-info 1:0:0
34
35libexec_PROGRAMS = \
36 gnunet-service-identity
37
38gnunet_service_identity_SOURCES = \
39 gnunet-service-identity.c
40gnunet_service_identity_LDADD = \
41 libgnunetidentity.la \
42 $(top_builddir)/src/statistics/libgnunetstatistics.la \
43 $(top_builddir)/src/lib/util/libgnunetutil.la \
44 $(GN_LIBINTL)
45
46
47check_PROGRAMS = \
48 test_identity
49
50# if ENABLE_TEST_RUN
51# AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
52# TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
53# endif
54
55
56test_identity_SOURCES = \
57 test_identity.c
58test_identity_LDADD = \
59 libgnunetidentity.la \
60 $(top_builddir)/src/lib/testing/libgnunettesting.la \
61 $(top_builddir)/src/lib/util/libgnunetutil.la
62
63EXTRA_DIST = \
64 test_identity.conf \
65 test_identity_messages.sh
66
67