aboutsummaryrefslogtreecommitdiff
path: root/src/service/namestore/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/namestore/meson.build')
-rw-r--r--src/service/namestore/meson.build56
1 files changed, 56 insertions, 0 deletions
diff --git a/src/service/namestore/meson.build b/src/service/namestore/meson.build
index 912b312fa..616c8ad01 100644
--- a/src/service/namestore/meson.build
+++ b/src/service/namestore/meson.build
@@ -55,3 +55,59 @@ executable ('gnunet-namestore-fcfsd',
55 install: true, 55 install: true,
56 install_dir: get_option('libdir')/'gnunet'/'libexec') 56 install_dir: get_option('libdir')/'gnunet'/'libexec')
57 57
58
59configure_file(copy: true,
60 input: 'test_namestore_api.conf',
61 output: 'test_namestore_api.conf')
62
63configure_file(copy: true,
64 input: 'test_namestore_api_sqlite.conf',
65 output: 'test_namestore_api_sqlite.conf')
66
67namestoreapitestnames = [
68 'test_namestore_api_edit_records',
69 'test_namestore_api_lookup_nick',
70 'test_namestore_api_monitoring',
71 'test_namestore_api_monitoring_existing',
72 'test_namestore_api_remove',
73 'test_namestore_api_remove_not_existing_record',
74 'test_namestore_api_store',
75 'test_namestore_api_store_update',
76 'test_namestore_api_tx_rollback',
77 'test_namestore_api_zone_iteration',
78 'test_namestore_api_zone_iteration_nick',
79 'test_namestore_api_zone_iteration_specific_zone',
80 'test_namestore_api_zone_iteration_stop',
81 'test_namestore_api_zone_to_name'
82 ]
83
84foreach tn : namestoreapitestnames
85 t = executable (tn + '_sqlite',
86 [tn + '.c'],
87 dependencies: [
88 libgnunettesting_dep,
89 libgnunetutil_dep,
90 libgnunetgnsrecord_dep,
91 libgnunetidentity_dep,
92 libgnunetnamestore_dep],
93 include_directories: [incdir, configuration_inc],
94 install: false)
95 test(tn + '_sqlite', t, workdir: meson.current_build_dir(),
96 suite: 'namestore')
97 if pq_dep.found()
98 t_pq = executable (tn + '_postgres',
99 [tn + '.c'],
100 dependencies: [
101 libgnunettesting_dep,
102 libgnunetutil_dep,
103 libgnunetgnsrecord_dep,
104 libgnunetidentity_dep,
105 libgnunetnamestore_dep],
106 include_directories: [incdir, configuration_inc],
107 install: false)
108 test(tn + '_postgres', t, workdir: meson.current_build_dir(),
109 suite: 'namestore')
110 endif
111endforeach
112
113# FIXME perf tests missing