aboutsummaryrefslogtreecommitdiff
path: root/src/service/nat-auto/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/nat-auto/Makefile.am')
-rw-r--r--src/service/nat-auto/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/service/nat-auto/Makefile.am b/src/service/nat-auto/Makefile.am
new file mode 100644
index 000000000..d34a16761
--- /dev/null
+++ b/src/service/nat-auto/Makefile.am
@@ -0,0 +1,40 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4libexecdir= $(pkglibdir)/libexec/
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8pkgcfg_DATA = \
9 nat-auto.conf
10
11libexec_PROGRAMS = \
12 gnunet-service-nat-auto
13
14if USE_COVERAGE
15 AM_CFLAGS = -fprofile-arcs -ftest-coverage
16endif
17
18lib_LTLIBRARIES = \
19 libgnunetnatauto.la
20
21libgnunetnatauto_la_SOURCES = \
22 nat_auto_api.c \
23 nat_auto_api_test.c
24libgnunetnatauto_la_LIBADD = \
25 $(top_builddir)/src/service/nat/libgnunetnatnew.la \
26 $(top_builddir)/src/lib/util/libgnunetutil.la \
27 $(GN_LIBINTL) @EXT_LIBS@
28libgnunetnatauto_la_LDFLAGS = \
29 $(GN_LIB_LDFLAGS) \
30 -version-info 0:0:0
31
32gnunet_service_nat_auto_SOURCES = \
33 gnunet-service-nat-auto.c nat-auto.h
34gnunet_service_nat_auto_LDADD = \
35 $(top_builddir)/src/lib/util/libgnunetutil.la \
36 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
37 $(top_builddir)/src/service/nat/libgnunetnatnew.la \
38 $(LIBGCRYPT_LIBS) \
39 -lgcrypt \
40 $(GN_LIBINTL)