aboutsummaryrefslogtreecommitdiff
path: root/src/service/nat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/nat/Makefile.am')
-rw-r--r--src/service/nat/Makefile.am106
1 files changed, 106 insertions, 0 deletions
diff --git a/src/service/nat/Makefile.am b/src/service/nat/Makefile.am
new file mode 100644
index 000000000..d6cbe94f1
--- /dev/null
+++ b/src/service/nat/Makefile.am
@@ -0,0 +1,106 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4libexecdir= $(pkglibdir)/libexec/
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8pkgcfg_DATA = \
9 nat.conf
10
11if LINUX
12 NATBIN = gnunet-helper-nat-server gnunet-helper-nat-client
13 NATSERVER = gnunet-helper-nat-server.c
14 NATCLIENT = gnunet-helper-nat-client.c
15else
16if XFREEBSD
17 NATBIN = gnunet-helper-nat-server gnunet-helper-nat-client
18 NATSERVER = gnunet-helper-nat-server.c
19 NATCLIENT = gnunet-helper-nat-client.c
20endif
21else
22install-exec-hook:
23endif
24
25libexec_PROGRAMS = \
26 $(NATBIN) \
27 gnunet-service-nat
28
29
30gnunet_helper_nat_server_SOURCES = \
31 $(NATSERVER)
32
33gnunet_helper_nat_client_SOURCES = \
34 $(NATCLIENT)
35
36
37if USE_COVERAGE
38 AM_CFLAGS = -fprofile-arcs -ftest-coverage
39endif
40
41lib_LTLIBRARIES = \
42 libgnunetnatnew.la
43
44libgnunetnatnew_la_SOURCES = \
45 nat_api.c \
46 nat_api_stun.c nat_stun.h \
47 nat.h
48libgnunetnatnew_la_LIBADD = \
49 $(top_builddir)/src/lib/util/libgnunetutil.la \
50 $(GN_LIBINTL) @EXT_LIBS@
51libgnunetnatnew_la_LDFLAGS = \
52 $(GN_LIB_LDFLAGS) \
53 -version-info 2:0:0
54
55gnunet_service_nat_SOURCES = \
56 gnunet-service-nat.c gnunet-service-nat.h \
57 gnunet-service-nat_externalip.c gnunet-service-nat_externalip.h \
58 gnunet-service-nat_stun.c gnunet-service-nat_stun.h \
59 gnunet-service-nat_mini.c gnunet-service-nat_mini.h \
60 gnunet-service-nat_helper.c gnunet-service-nat_helper.h
61gnunet_service_nat_LDADD = \
62 $(top_builddir)/src/lib/util/libgnunetutil.la \
63 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
64 $(LIBGCRYPT_LIBS) \
65 -lgcrypt \
66 $(GN_LIBINTL)
67
68#check_PROGRAMS = \
69# test_nat \
70# test_nat_mini \
71# test_nat_test \
72# test_stun
73
74if ENABLE_TEST_RUN
75 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
76 TESTS = $(check_PROGRAMS)
77endif
78
79#test_nat_SOURCES = \
80# test_nat.c
81#test_nat_LDADD = \
82# libgnunetnat.la \
83# $(top_builddir)/src/lib/util/libgnunetutil.la
84
85#test_nat_mini_SOURCES = \
86# test_nat_mini.c
87#test_nat_mini_LDADD = \
88# libgnunetnat.la \
89# $(top_builddir)/src/lib/util/libgnunetutil.la
90
91#test_nat_test_SOURCES = \
92# test_nat_test.c
93#test_nat_test_LDADD = \
94# libgnunetnat.la \
95# $(top_builddir)/src/lib/util/libgnunetutil.la
96
97#test_stun_SOURCES = \
98# test_stun.c
99#test_stun_LDADD = \
100# libgnunetnat.la \
101# $(top_builddir)/src/lib/util/libgnunetutil.la
102
103EXTRA_DIST = \
104 test_nat_data.conf \
105 test_nat_test_data.conf \
106 test_stun.conf