aboutsummaryrefslogtreecommitdiff
path: root/src/service/peerstore/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/peerstore/meson.build')
-rw-r--r--src/service/peerstore/meson.build95
1 files changed, 95 insertions, 0 deletions
diff --git a/src/service/peerstore/meson.build b/src/service/peerstore/meson.build
new file mode 100644
index 000000000..2c1ef4a67
--- /dev/null
+++ b/src/service/peerstore/meson.build
@@ -0,0 +1,95 @@
1libgnunetpeerstore_src = ['peerstore_api.c',
2 'peerstore_api_monitor.c',
3 'peerstore_common.c']
4
5gnunetservicepeerstore_src = ['gnunet-service-peerstore.c']
6
7configure_file(input : 'peerstore.conf.in',
8 output : 'peerstore.conf',
9 configuration : cdata,
10 install: true,
11 install_dir: pkgcfgdir)
12
13
14if get_option('monolith')
15 foreach p : libgnunetpeerstore_src + gnunetservicepeerstore_src
16 gnunet_src += 'peerstore/' + p
17 endforeach
18endif
19
20libgnunetpeerstore = library('gnunetpeerstore',
21 libgnunetpeerstore_src,
22 soversion: '0',
23 version: '0.0.0',
24 dependencies: [libgnunetutil_dep, libgnunethello_dep],
25 include_directories: [incdir, configuration_inc],
26 install: true,
27 install_dir: get_option('libdir'))
28pkg.generate(libgnunetpeerstore, url: 'https://www.gnunet.org',
29 description : 'Provides API for accessing the peerstore service')
30libgnunetpeerstore_dep = declare_dependency(link_with : libgnunetpeerstore)
31
32executable ('gnunet-service-peerstore',
33 gnunetservicepeerstore_src,
34 dependencies: [libgnunetpeerstore_dep,
35 libgnunetutil_dep,
36 libgnunethello_dep],
37 include_directories: [incdir, configuration_inc],
38 install: true,
39 install_dir: get_option('libdir') / 'gnunet' / 'libexec')
40
41if false
42
43testpeerstore_api_iterate = executable ('test_peerstore_api_iterate',
44 ['test_peerstore_api_iterate.c'],
45 dependencies: [
46 libgnunetpeerstore_dep,
47 libgnunettesting_dep,
48 libgnunetutil_dep
49 ],
50 include_directories: [incdir, configuration_inc],
51 install: false)
52
53testpeerstore_api_store = executable ('test_peerstore_api_store',
54 ['test_peerstore_api_store.c'],
55 dependencies: [
56 libgnunetpeerstore_dep,
57 libgnunetutil_dep,
58 libgnunettesting_dep,
59 ],
60 include_directories: [incdir, configuration_inc],
61 install: false)
62
63testpeerstore_api_watch = executable ('test_peerstore_api_watch',
64 ['test_peerstore_api_watch.c'],
65 dependencies: [
66 libgnunetpeerstore_dep,
67 libgnunetutil_dep,
68 libgnunettesting_dep,
69 ],
70 include_directories: [incdir, configuration_inc],
71 install: false)
72testpeerstore_api_perf = executable ('perf_peerstore_store',
73 ['perf_peerstore_store.c'],
74 dependencies: [
75 libgnunetpeerstore_dep,
76 libgnunetutil_dep,
77 libgnunettesting_dep,
78 ],
79 include_directories: [incdir, configuration_inc],
80 install: false)
81
82configure_file(input : 'test_peerstore_api_data.conf',
83 output : 'test_peerstore_api_data.conf',
84 copy: true)
85
86test('test_peerstore_api_store', testpeerstore_api_store,
87 suite: 'peerstore', workdir: meson.current_build_dir())
88test('test_peerstore_api_watch', testpeerstore_api_watch,
89 suite: 'peerstore', workdir: meson.current_build_dir())
90test('test_peerstore_api_iterate', testpeerstore_api_iterate,
91 suite: 'peerstore', workdir: meson.current_build_dir())
92test('perf_peerstore_api_store', testpeerstore_api_perf,
93 suite: 'peerstore', workdir: meson.current_build_dir())
94
95endif \ No newline at end of file