aboutsummaryrefslogtreecommitdiff
path: root/src/service/peerstore/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/peerstore/meson.build')
-rw-r--r--src/service/peerstore/meson.build55
1 files changed, 55 insertions, 0 deletions
diff --git a/src/service/peerstore/meson.build b/src/service/peerstore/meson.build
index db70b0b9e..2c6f7eba8 100644
--- a/src/service/peerstore/meson.build
+++ b/src/service/peerstore/meson.build
@@ -37,3 +37,58 @@ executable ('gnunet-service-peerstore',
37 install: true, 37 install: true,
38 install_dir: get_option('libdir') / 'gnunet' / 'libexec') 38 install_dir: get_option('libdir') / 'gnunet' / 'libexec')
39 39
40testpeerstore_api_iterate = executable ('test_peerstore_api_iterate',
41 ['test_peerstore_api_iterate.c'],
42 dependencies: [
43 libgnunetpeerstore_dep,
44 libgnunettesting_dep,
45 libgnunetutil_dep
46 ],
47 include_directories: [incdir, configuration_inc],
48 install: false)
49
50testpeerstore_api_store = executable ('test_peerstore_api_store',
51 ['test_peerstore_api_store.c'],
52 dependencies: [
53 libgnunetpeerstore_dep,
54 libgnunetutil_dep,
55 libgnunettesting_dep,
56 ],
57 include_directories: [incdir, configuration_inc],
58 install: false)
59
60testpeerstore_api_watch = executable ('test_peerstore_api_watch',
61 ['test_peerstore_api_watch.c'],
62 dependencies: [
63 libgnunetpeerstore_dep,
64 libgnunetutil_dep,
65 libgnunettesting_dep,
66 ],
67 include_directories: [incdir, configuration_inc],
68 install: false)
69testpeerstore_api_perf = executable ('perf_peerstore_store',
70 ['perf_peerstore_store.c'],
71 dependencies: [
72 libgnunetpeerstore_dep,
73 libgnunetutil_dep,
74 libgnunettesting_dep,
75 ],
76 include_directories: [incdir, configuration_inc],
77 install: false)
78
79configure_file(input : 'test_peerstore_api_data.conf',
80 output : 'test_peerstore_api_data.conf',
81 copy: true)
82
83test('test_peerstore_api_store', testpeerstore_api_store,
84 suite: 'peerstore', workdir: meson.current_build_dir())
85test('test_peerstore_api_watch', testpeerstore_api_watch,
86 suite: 'peerstore', workdir: meson.current_build_dir())
87test('test_peerstore_api_iterate', testpeerstore_api_iterate,
88 suite: 'peerstore', workdir: meson.current_build_dir())
89test('perf_peerstore_store', testpeerstore_api_perf,
90 suite: 'peerstore', workdir: meson.current_build_dir())
91
92
93
94