aboutsummaryrefslogtreecommitdiff
path: root/src/service/regex/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/regex/Makefile.am')
-rw-r--r--src/service/regex/Makefile.am139
1 files changed, 139 insertions, 0 deletions
diff --git a/src/service/regex/Makefile.am b/src/service/regex/Makefile.am
new file mode 100644
index 000000000..63c166a23
--- /dev/null
+++ b/src/service/regex/Makefile.am
@@ -0,0 +1,139 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage
6endif
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10libexecdir= $(pkglibdir)/libexec/
11
12plugindir = $(libdir)/gnunet
13
14pkgcfg_DATA = \
15 regex.conf
16
17libexec_PROGRAMS = \
18 gnunet-service-regex \
19 gnunet-daemon-regexprofiler
20
21REGEX_INTERNAL = \
22 regex_internal_lib.h \
23 regex_internal.h regex_internal.c \
24 regex_internal_dht.c
25REGEX_INTERNAL_TEST = \
26 $(REGEX_INTERNAL) \
27 regex_test_lib.c regex_test_lib.h \
28 regex_test_graph.c \
29 regex_test_random.c
30
31gnunet_service_regex_SOURCES = \
32 $(REGEX_INTERNAL) gnunet-service-regex.c
33gnunet_service_regex_LDADD = -lm \
34 $(top_builddir)/src/plugin/regex/libgnunetregexblock.la \
35 $(top_builddir)/src/service/dht/libgnunetdht.la \
36 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
37 $(top_builddir)/src/lib/util/libgnunetutil.la \
38 $(GN_LIBINTL)
39
40lib_LTLIBRARIES = \
41 libgnunetregex.la
42
43libgnunetregex_la_SOURCES = \
44 regex_api_announce.c \
45 regex_api_search.c \
46 regex_ipc.h
47libgnunetregex_la_LIBADD = \
48 $(top_builddir)/src/lib/util/libgnunetutil.la
49libgnunetregex_la_LDFLAGS = \
50 $(GN_LIBINTL) \
51 $(GN_LIB_LDFLAGS) \
52 -version-info 3:1:0
53
54
55noinst_PROGRAMS = $(noinst_mysql_progs) \
56 perf-regex
57
58perf_regex_SOURCES = \
59 $(REGEX_INTERNAL_TEST) perf-regex.c
60perf_regex_LDADD = -lm \
61 $(top_builddir)/src/service/dht/libgnunetdht.la \
62 $(top_builddir)/src/plugin/regex/libgnunetregexblock.la \
63 $(top_builddir)/src/lib/util/libgnunetutil.la \
64 $(top_builddir)/src/service/statistics/libgnunetstatistics.la
65perf_regex_LDFLAGS = \
66 $(GN_LIBINTL)
67
68gnunet_daemon_regexprofiler_SOURCES = \
69 $(REGEX_INTERNAL_TEST) gnunet-daemon-regexprofiler.c
70gnunet_daemon_regexprofiler_LDADD = -lm \
71 $(top_builddir)/src/service/dht/libgnunetdht.la \
72 $(top_builddir)/src/plugin/regex/libgnunetregexblock.la \
73 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
74 $(top_builddir)/src/lib/util/libgnunetutil.la
75gnunet_daemon_regexprofiler_LDFLAGS = \
76 $(GN_LIBINTL)
77
78#check_PROGRAMS = \
79# test_regex_integration \
80# test_regex_eval_api \
81# test_regex_iterate_api \
82# test_regex_proofs \
83# test_regex_graph_api \
84# test_regex_api
85
86if ENABLE_TEST_RUN
87 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
88 TESTS = $(check_PROGRAMS)
89endif
90
91test_regex_eval_api_SOURCES = \
92 $(REGEX_INTERNAL_TEST) test_regex_eval_api.c
93test_regex_eval_api_LDADD = -lm \
94 $(top_builddir)/src/service/dht/libgnunetdht.la \
95 $(top_builddir)/src/plugin/regex/libgnunetregexblock.la \
96 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
97 $(top_builddir)/src/lib/util/libgnunetutil.la
98
99test_regex_integration_SOURCES = \
100 test_regex_integration.c
101test_regex_integration_LDADD = -lm \
102 libgnunetregex.la \
103 $(top_builddir)/src/service/testing/libgnunettesting.la \
104 $(top_builddir)/src/lib/util/libgnunetutil.la
105
106test_regex_api_SOURCES = \
107 test_regex_api.c
108test_regex_api_LDADD = -lm \
109 libgnunetregex.la \
110 $(top_builddir)/src/service/testing/libgnunettesting.la \
111 $(top_builddir)/src/lib/util/libgnunetutil.la
112
113test_regex_iterate_api_SOURCES = \
114 $(REGEX_INTERNAL) test_regex_iterate_api.c
115test_regex_iterate_api_LDADD = -lm \
116 $(top_builddir)/src/plugin/regex/libgnunetregexblock.la \
117 $(top_builddir)/src/service/dht/libgnunetdht.la \
118 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
119 $(top_builddir)/src/lib/util/libgnunetutil.la
120
121test_regex_proofs_SOURCES = \
122 $(REGEX_INTERNAL_TEST) test_regex_proofs.c
123test_regex_proofs_LDADD = -lm \
124 $(top_builddir)/src/service/dht/libgnunetdht.la \
125 $(top_builddir)/src/plugin/regex/libgnunetregexblock.la \
126 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
127 $(top_builddir)/src/lib/util/libgnunetutil.la
128
129test_regex_graph_api_SOURCES = \
130 $(REGEX_INTERNAL_TEST) test_regex_graph_api.c
131test_regex_graph_api_LDADD = -lm \
132 $(top_builddir)/src/service/dht/libgnunetdht.la \
133 $(top_builddir)/src/plugin/regex/libgnunetregexblock.la \
134 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
135 $(top_builddir)/src/lib/util/libgnunetutil.la
136
137
138EXTRA_DIST = \
139 test_regex_api_data.conf