aboutsummaryrefslogtreecommitdiff
path: root/src/service/regex/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/regex/meson.build')
-rw-r--r--src/service/regex/meson.build57
1 files changed, 57 insertions, 0 deletions
diff --git a/src/service/regex/meson.build b/src/service/regex/meson.build
new file mode 100644
index 000000000..3c25a5148
--- /dev/null
+++ b/src/service/regex/meson.build
@@ -0,0 +1,57 @@
1libgnunetregex_src = ['regex_api_announce.c',
2 'regex_api_search.c']
3gnunetserviceregex_src = ['gnunet-service-regex.c',
4 'regex_internal_dht.c',
5 'regex_internal.c']
6
7configure_file(input : 'regex.conf.in',
8 output : 'regex.conf',
9 configuration : cdata,
10 install: true,
11 install_dir: pkgcfgdir)
12
13
14if get_option('monolith')
15 foreach p : libgnunetregex_src + gnunetserviceregex_src
16 gnunet_src += 'regex/' + p
17 endforeach
18endif
19
20libgnunetregex = library('gnunetregex',
21 libgnunetregex_src,
22 soversion: '3',
23 version: '3.0.1',
24 dependencies: libgnunetutil_dep,
25 include_directories: [incdir, configuration_inc],
26 install: true,
27 install_dir: get_option('libdir'))
28pkg.generate(libgnunetregex, url: 'https://www.gnunet.org',
29 description : 'Provides API for accessing the regex service')
30libgnunetregex_dep = declare_dependency(link_with : libgnunetregex)
31
32executable ('gnunet-service-regex',
33 gnunetserviceregex_src,
34 dependencies: [libgnunetregex_dep, libgnunetutil_dep,
35 libgnunetdht_dep,
36 libgnunetstatistics_dep,
37 libgnunetregex_dep,
38 libgnunetregexblock_dep],
39 include_directories: [incdir, configuration_inc],
40 install: true,
41 install_dir: get_option('libdir')/'gnunet'/'libexec')
42executable ('gnunet-daemon-regexprofiler',
43 ['gnunet-daemon-regexprofiler.c',
44 'regex_internal.c',
45 'regex_internal_dht.c',
46 'regex_test_lib.c',
47 'regex_test_graph.c',
48 'regex_test_random.c'],
49 dependencies: [libgnunetregex_dep, libgnunetutil_dep,
50 libgnunetdht_dep,
51 libgnunetstatistics_dep,
52 libgnunetregex_dep,
53 libgnunetregexblock_dep],
54 include_directories: [incdir, configuration_inc],
55 install: true,
56 install_dir: get_option('libdir')/'gnunet'/'libexec')
57