aboutsummaryrefslogtreecommitdiff
path: root/src/service/rest/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/rest/Makefile.am')
-rw-r--r--src/service/rest/Makefile.am75
1 files changed, 75 insertions, 0 deletions
diff --git a/src/service/rest/Makefile.am b/src/service/rest/Makefile.am
new file mode 100644
index 000000000..69c0235cc
--- /dev/null
+++ b/src/service/rest/Makefile.am
@@ -0,0 +1,75 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10pkgcfg_DATA = \
11 rest.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = --coverage -O0
15 XLIBS = -lgcov
16endif
17
18lib_LTLIBRARIES = \
19 libgnunetrest.la
20
21libexec_PROGRAMS = \
22 gnunet-rest-server
23
24EXTRA_DIST = \
25 rest.conf
26
27if HAVE_JOSE
28OPENID_PLUGIN = \
29 openid_plugin.c \
30 openid_plugin.h \
31 oidc_helper.c \
32 oidc_helper.h
33OPENID_JOSE_LIBS = -ljose
34endif
35
36gnunet_rest_server_SOURCES = \
37 gnunet-rest-server.c \
38 config_plugin.c \
39 config_plugin.h \
40 copying_plugin.c \
41 copying_plugin.h \
42 identity_plugin.c \
43 identity_plugin.h \
44 namestore_plugin.c \
45 namestore_plugin.h \
46 gns_plugin.c \
47 gns_plugin.h \
48 $(OPENID_PLUGIN) \
49 reclaim_plugin.c json_reclaim.c \
50 reclaim_plugin.h json_reclaim.h
51gnunet_rest_server_LDADD = \
52 $(top_builddir)/src/lib/util/libgnunetutil.la \
53 $(top_builddir)/src/lib/json/libgnunetjson.la \
54 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
55 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecordjson.la \
56 $(top_builddir)/src/service/identity/libgnunetidentity.la \
57 $(top_builddir)/src/service/namestore/libgnunetnamestore.la \
58 $(top_builddir)/src/service/gns/libgnunetgns.la \
59 $(top_builddir)/src/service/reclaim/libgnunetreclaim.la \
60 libgnunetrest.la \
61 $(OPENID_JOSE_LIBS) \
62 -ljansson \
63 $(LIBGCRYPT_LIBS) \
64 $(GN_LIBINTL) $(MHD_LIBS)
65gnunet_rest_server_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
66
67libgnunetrest_la_SOURCES = \
68 rest.c
69libgnunetrest_la_LIBADD = \
70 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIB) \
71 $(GN_LIBINTL) $(MHD_LIBS)
72libgnunetrest_la_LDFLAGS = \
73 $(GN_LIB_LDFLAGS) \
74 -version-info 0:0:0
75libgnunetrest_la_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)