aboutsummaryrefslogtreecommitdiff
path: root/src/service/rest/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/rest/Makefile.am')
-rw-r--r--src/service/rest/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/service/rest/Makefile.am b/src/service/rest/Makefile.am
index 60769e366..3cb56c1d4 100644
--- a/src/service/rest/Makefile.am
+++ b/src/service/rest/Makefile.am
@@ -27,19 +27,27 @@ EXTRA_DIST = \
27if HAVE_JOSE 27if HAVE_JOSE
28OPENID_PLUGIN = \ 28OPENID_PLUGIN = \
29 openid_plugin.c \ 29 openid_plugin.c \
30 openid_plugin.h \
30 oidc_helper.c 31 oidc_helper.c
32 oidc_helper.h
31OPENID_JOSE_LIBS = -ljose 33OPENID_JOSE_LIBS = -ljose
32endif 34endif
33 35
34gnunet_rest_server_SOURCES = \ 36gnunet_rest_server_SOURCES = \
35 gnunet-rest-server.c \ 37 gnunet-rest-server.c \
36 config_plugin.c \ 38 config_plugin.c \
39 config_plugin.h \
37 copying_plugin.c \ 40 copying_plugin.c \
41 copying_plugin.h \
38 identity_plugin.c \ 42 identity_plugin.c \
43 identity_plugin.h \
39 namestore_plugin.c \ 44 namestore_plugin.c \
45 namestore_plugin.h \
40 gns_plugin.c \ 46 gns_plugin.c \
47 gns_plugin.h \
41 $(OPENID_PLUGIN) \ 48 $(OPENID_PLUGIN) \
42 reclaim_plugin.c json_reclaim.c 49 reclaim_plugin.c json_reclaim.c
50 reclaim_plugin.h json_reclaim.h
43gnunet_rest_server_LDADD = \ 51gnunet_rest_server_LDADD = \
44 $(top_builddir)/src/lib/util/libgnunetutil.la \ 52 $(top_builddir)/src/lib/util/libgnunetutil.la \
45 $(top_builddir)/src/lib/json/libgnunetjson.la \ 53 $(top_builddir)/src/lib/json/libgnunetjson.la \