aboutsummaryrefslogtreecommitdiff
path: root/src/service/rest/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/rest/meson.build')
-rw-r--r--src/service/rest/meson.build58
1 files changed, 58 insertions, 0 deletions
diff --git a/src/service/rest/meson.build b/src/service/rest/meson.build
new file mode 100644
index 000000000..2dd3d8de4
--- /dev/null
+++ b/src/service/rest/meson.build
@@ -0,0 +1,58 @@
1libgnunetrest_src = ['rest.c']
2
3gnunetservicerest_src = ['gnunet-rest-server.c']
4
5configure_file(input : 'rest.conf',
6 output : 'rest.conf',
7 configuration : cdata,
8 install: true,
9 install_dir: pkgcfgdir)
10
11
12if get_option('monolith')
13 foreach p : libgnunetrest_src + gnunetservicerest_src
14 gnunet_src += 'rest/' + p
15 endforeach
16 subdir_done()
17endif
18
19
20libgnunetrest = library('gnunetrest',
21 libgnunetrest_src,
22 soversion: '0',
23 version: '0.0.0',
24 dependencies: [libgnunetutil_dep, mhd_dep],
25 include_directories: [incdir, configuration_inc],
26 install: true,
27 install_dir: get_option('libdir'))
28pkg.generate(libgnunetrest, url: 'https://www.gnunet.org',
29 description : 'Provides API for accessing the REST service')
30libgnunetrest_dep = declare_dependency(link_with : libgnunetrest)
31
32shared_module('gnunet_plugin_rest_config',
33 ['plugin_rest_config.c'],
34 dependencies: [libgnunetrest_dep,
35 libgnunetutil_dep,
36 json_dep,
37 mhd_dep],
38 include_directories: [incdir, configuration_inc],
39 install: true,
40 install_dir: get_option('libdir') / 'gnunet')
41shared_module('gnunet_plugin_rest_copying',
42 ['plugin_rest_copying.c'],
43 dependencies: [libgnunetrest_dep,
44 libgnunetutil_dep,
45 json_dep,
46 mhd_dep],
47 include_directories: [incdir, configuration_inc],
48 install: true,
49 install_dir: get_option('libdir') / 'gnunet')
50
51
52executable ('gnunet-rest-server',
53 gnunetservicerest_src,
54 dependencies: [libgnunetrest_dep, libgnunetutil_dep, mhd_dep],
55 include_directories: [incdir, configuration_inc],
56 install: true,
57 install_dir: get_option('libdir') / 'gnunet' / 'libexec')
58